Announcement

Collapse
No announcement yet.

Google adsense partaily not appear after upgrading

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Google adsense partaily not appear after upgrading

    from days ago i move my vbulletin website to new server ,install ssl certificate and upgrade from vb4.2 to vb4.5 but unfortunately after that i noticed that the adsense code which i inserted in thread first post , as second post and in navbar some time work and ad appear in the threads and in other threads don't work and the page appear without ad

    also i noticed that in most cases of this problem if the thread URL appear in the following form
    https://www.******/vb/threads/93755-show thread-name?p=359944#post359999

    the ad not work in the thread , but if i change the thread url to appear without post number as the following

    https://www.******/vb/threads/93755-show thread-name

    the ad work in the thread without problem

    and in a little cases the the Reverse of the above need to be done to ad work , i mean that the post number must appear in thread url titles for ad to work (****/93755-show thread-name?p=359944#post359999)

    so what the cause of this problem and how i can solve them

  • #2
    If your code is quite old try regenerating it in AdSense and use the asynchronous option

    I'd try just one to start with and see if it works, keeping a copy of your old code so you can put it back if necessary.

    Asynchronous code is supposed to work better, it certainly helped when we moved from v4 to 5 and had problems with AdSense not showing.

    More here about it: https://support.google.com/adsense/a...21666?hl=en-GB
    __________________________________________
    We don't stop playing because we grow old;
    we grow old because we stop playing.
    GBS

    Comment


    • #3
      Originally posted by MrsTiggywinkle View Post
      If your code is quite old try regenerating it in AdSense and use the asynchronous option

      I'd try just one to start with and see if it works, keeping a copy of your old code so you can put it back if necessary.

      Asynchronous code is supposed to work better, it certainly helped when we moved from v4 to 5 and had problems with AdSense not showing.

      More here about it: https://support.google.com/adsense/a...21666?hl=en-GB
      i try that actually and it succeed only in the home page and ad work when change to asynchronous code but in the thread page not succeeded and ad not work with both in the effected thread

      Comment


      • #4
        i found that if i open thread without include postid in URL the ad work inside the threads , so if any one can help me to redirect url containing postid to url without it

        for example

        Redirect
        threads/1234-Thread-Title?p=342222#post342222
        to
        threads/1234-Thread-Title

        is there any .htaccess rules can help in that
        Last edited by khalled; Sat 20th Jan '18, 5:55pm.

        Comment


        • #5
          can any one help in that

          Comment


          • #6
            You cannot redirect vBulletin URLs like that.

            What is the actual content of your module?
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Originally posted by Mark.B View Post
              You cannot redirect vBulletin URLs like that.

              What is the actual content of your module?
              it is engineering discussion forum by vbulletin vb4.2.5 and i insert ad code in the first post , navbar and as second post

              can i remove postid from thread URL , and disable postid link in thread page like thread vbulletin.com
              Last edited by khalled; Mon 22nd Jan '18, 2:04pm.

              Comment

              Working...
              X