Announcement

Collapse
No announcement yet.

Error to update from 4.2.1 to 4.2.5

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error to update from 4.2.1 to 4.2.5

    This morning, during the update of the vbulletin script from 4.2.1 to 4.2.5, I had this error

    PHP Code:
    Error point 18/20

    Unexpected Text:

    <?xml version="1.0" encoding="windows-1252"?>
    <br />
    <b>Warning</b>:  mysqli_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ' )
                                       )
                                       WHERE ipid IS NULL' at line 6 in <b>/data/vhosts/collectiontricks.it/httpdocs/includes/class_core.php</b> on line <b>1386</b><br />
    <?xml version="1.0" encoding="windows-1252"?>
    <errors>
                <error><![CDATA[<p>Database Error</p>

    Invalid SQL:

                                       SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid
                                       FROM vb_blog_text bt
                                       JOIN vb_blog bl USING (blogid)
                                       LEFT JOIN vb_ipdata ip ON (
                                                   bt.ipaddress = ip.ipid AND bt.blogtextid  = ip.contentid
                                                   AND bt.userid = ip.userid AND ip.contenttypeid IN (, )
                                       )
                                       WHERE ipid IS NULL;

    You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ' )
                                       )
                                       WHERE ipid IS NULL' at line 6]]></error>
                <error_html><![CDATA[<p>Database error in vBulletin 4.2.5</p>
    <p>Invalid SQL:

                                       SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid
                                       FROM vb_blog_text bt
                                       JOIN vb_blog bl USING (blogid)
                                       LEFT JOIN vb_ipdata ip ON (
                                                   bt.ipaddress = ip.ipid AND bt.blogtextid  = ip.contentid
                                                   AND bt.userid = ip.userid AND ip.contenttypeid IN (, )
                                       )
                                       WHERE ipid IS NULL;<p>
    <p>
    <strong>MySQL Error</strong>   : You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ' )
                                       )
                                       WHERE ipid IS NULL' at line 6<br />
    <strong>Error Number</strong>  : 1064<br />
    <strong>Request Date</strong>  : Friday, August 4th 2017 @ 09:09:54 AM<br />
    <strong>Error Date</strong>    : Friday, August 4th 2017 @ 09:09:55 AM<br />
    <strong>Script</strong>        : http://www.collectiontricks.it/install/upgrade.php<br />
    <strong>Referrer</strong>      : https://www.collectiontricks.it/install/upgrade.php<br />
    <strong>Classname</strong>     : vB_Database_MySQLi<br />
    <strong>MySQL Version</strong> : 10.0.31-MariaDB-cll-lve<br />
    </p>]]></error_html>
    </errors>
    This is my setting

    Server SQL Server: Localhost via UNIX socket
    Server Type: MariaDB
    Server Version: 10.0.31-MariaDB-cll-lve - MariaDB
    Server Protocol version: 10
    Codifica caratteri del server: UTF-8 Unicode (utf8)

    PHP version 5.6.31

    Can you help me, thanks

  • #2
    Sorry the solution are here
    The site was running on php version 5.6. I first changed the version to 7.1 and then wanted to upgrade vB to 4.2.5. There was an error about half way and the upgrade was aborted. Any thoughts on how to fix

    Comment


    • #3
      The fix is as the solution states, enable the blogs, then run the upgrade..
      This is my signature.

      Comment


      • #4
        Have this same error going from 4.2.2 to 4.2.5. Blogs are turned on, and PHP is at 7.1.12 but still getting this error halfway through the upgrad.
        Any help appreciated.

        Comment


        • #5
          Originally posted by XXP View Post
          Have this same error going from 4.2.2 to 4.2.5. Blogs are turned on, and PHP is at 7.1.12 but still getting this error halfway through the upgrad.
          Any help appreciated.
          If the fix mentioned doesn't work for you, please start your own thread with full details of the issue, including the exact error message.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.4.0 Demo - FEATURING "ROUTE BY NODE"!
          AdminAmmo - My Cloud Demo

          Comment

          Working...
          X