Announcement

Collapse
No announcement yet.

new thread error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] new thread error

    I upgrade on vBulletin 4.2.5.
    When i tried to make new thread, following error shown

    Call to undefined function split() on line 26 in /home/**********/newthread.php(77) : eval()'d code
    #0 /home/**********/newthread.php(77): eval()
    #1 {main}

    This error shown in some sections. some sections work fine

    I further check, when i disable this plugin then this error not appear

    Title: WoG - TLPXHONSF - ThreadAction
    Hook location: newthread_start

    PHP code
    PHP Code:
    if (($foruminfo['wog_create_max'] != '0') AND ($foruminfo['wog_create_hours'] != '0') AND ($vbulletin->options['wog_tlpxhonsf_enable']))
    {
        if (
    $vbulletin->options['wog_tlpxhonsf_onlyvisible'])
        {
            
    $wog_onlyvisible "AND `visible` = '1'";
        }
        else
        {
            
    $wog_onlyvisible '';
        }
        
    $wog_range = (TIMENOW - ($foruminfo['wog_create_hours'] * 3600));
        
    $wog_gethreads $db->query_first("
            SELECT COUNT(*) AS threadcount 
            FROM `" 
    TABLE_PREFIX "thread`
            WHERE `postuserid` = '" 
    $vbulletin->userinfo['userid'] . "'
            AND `forumid` = '" 
    $foruminfo['forumid'] . "'
            AND `dateline` > '" 
    $wog_range "'
            " 
    $wog_onlyvisible
        
    );
        
    $wog_denied false;
        if (
    $wog_gethreads['threadcount'] >= $foruminfo['wog_create_max'])
        {
            
    $wog_denied true;
        }
        
    $forumperms fetch_permissions($foruminfo['forumid']);
        if ((
    $vbulletin->userinfo['userid']) AND ($forumperms $vbulletin->bf_ugp_forumpermissions['canpostnew']) AND !(is_member_of($vbulletin->userinfosplit(','$vbulletin->options['wog_tlpxhonsf_excludedgroups']))) AND ($wog_denied))
        {
            eval(
    standard_error(fetch_error('error_wog_thread_limit'intval($foruminfo['wog_create_hours']), intval($foruminfo['wog_create_max']), intval($wog_gethreads['threadcount']))));
        }


  • #2
    Find in PHP code:
    split

    And replace it:
    explode

    Comment


    • #3
      Thats an issue with PHP7, not vbulletin 4.2.5.

      split() is not a valid function in php7 - change it as motd2 states above.
      This is my signature.

      Comment


      • #4
        Thank you so much motd2 and
        stingray27


        now its work fine

        Comment


        • #5
          Please note that issues with plugins/add-ons should be referred to the author of that over at www.vbulletin.org or wherever else you obtained it.
          Vote for:

          - *Admin Settable Paid Subscription Reminder Timeframe*
          -
          *PM - Add ability to reply to originator only*
          - Add Admin ability to auto-subscribe users to specific channel(s)
          - Highlight the correct navigation tab when you are on a custom page
          - "Quick Route" Interface...
          - Allow to use custom icons for individual forums

          Comment


          • #6
            Originally posted by Trevor Hannant View Post
            Please note that issues with plugins/add-ons should be referred to the author of that over at www.vbulletin.org or wherever else you obtained it.
            I just notice that this plugin is belong to this add-on and this add-on uninstalled almost one year ago. Its mean when anyone uninstall add-on, its plugin did not remove.
            Is it possible to restore forum on default setting and forum data (posts, attachments, messages, etc) not remove?
            Miscellaneous Hacks - WoG - Threads Limit Per X Hours on Specified Forum vBulletin 4.x Add-ons

            Comment


            • #8
              Originally posted by Trevor Hannant View Post
              When you uninstalled it, did you also remove any files you uploaded?
              This addon contains just one xml file. No file need to upload on server to install it and i didn't remove any file

              Comment


              • #9
                Sounds like an issue with the uninstall procedures of the Add-on. It should delete all of its plugins when it is uninstalled. You can delete the plugin from the Plugin Manager in the AdminCP.
                Last edited by Wayne Luke; Wed 19th Jul '17, 11:38am.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud site. vBulletin 5 API - Full / Mobile
                Please do not PM me for support unless I specifically ask for information to be delivered that way.

                Comment

                Working...
                X