Announcement

Collapse
No announcement yet.

Error on fresh installation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error on fresh installation

    An error has occurred with your database. Please contact vBulletin Support for assistance.
    Module: install, Step 2 Database Error:1071
    Specified key was too long; max key length is 767 bytes
    Query:

    CREATE TABLE adcriteria ( adid INT UNSIGNED NOT NULL DEFAULT '0', criteriaid VARCHAR(250) NOT NULL DEFAULT '', condition1 VARCHAR(250) NOT NULL DEFAULT '', condition2 VARCHAR(250) NOT NULL DEFAULT '', condition3 VARCHAR(250) NOT NULL DEFAULT '', PRIMARY KEY (adid,criteriaid) )

  • #2
    What version of MySQL are you using? We recommend MySQL 5.1.5 or higher. This issue can be caused by some UTF character sets.
    Last edited by Wayne Luke; Wed 13th Apr '16, 2:44pm.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    Vote for your most annoying bugs.
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      MySQL Version 5.5.47-0+deb8u1

      Comment


      • #4
        Hmmm... Debian must have changed something with indexes in that version. It should fail quietly and MYSQL will adjust the length as necessary. Though in 5.6+ it will throw an error. If you're using the utf8mb4 character set in MySQl, the table above can trigger this.



        Open /core/install/mysql-schema.php and find this line:
        Code:
            criteriaid VARCHAR(250) NOT NULL DEFAULT '',
        Replace it with:
        Code:
            criteriaid VARCHAR(190) NOT NULL DEFAULT '',
        I don't know if that is the only instance where this will happen as I haven't reviewed the entire file. If you change your database's character set to utf8 with the collation of utf8_general_ci, you shouldn't have this problem.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        Vote for your most annoying bugs.
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          Originally posted by Wayne Luke View Post
          If you change your database's character set to utf8 with the collation of utf8_general_ci, you shouldn't have this problem.
          How do you do this or fix this issue? Making the edit to the file didn't work. I am having this same install error (Fresh Install) and vbulletin 4.2.5 is the only software that I have this issue with. I am running mysql 5.6.36-cll-lve and php 7.1

          Xenforo, SMF, Wordpress, and Wotlab installed absolutely fine.

          Is it because of php 7.1? I really hope not. I did try switching to 5.6 and then running the install again... didn't work. And I verified I had switched to 5.6
          Last edited by twitch; Mon 23rd Oct '17, 12:28am.

          Comment


          • #6
            This is done in MySQL, not within vBulletin.

            Here is a tutorial:
            https://lxadm.com/MySQL:_changing_da...et_and_collate

            Here is the MySQL documentation:
            https://dev.mysql.com/doc/refman/5.7...-database.html

            Your hosting provider or server administrator can help with this task.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            Vote for your most annoying bugs.
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              Originally posted by Wayne Luke View Post
              This is done in MySQL, not within vBulletin.

              Here is a tutorial:
              https://lxadm.com/MySQL:_changing_da...et_and_collate

              Here is the MySQL documentation:
              https://dev.mysql.com/doc/refman/5.7...-database.html

              Your hosting provider or server administrator can help with this task.
              Is 4.2.5 really that old that I can't install it without having to do this? I just got this hosting from A2hosting a week ago. Verified with them that settings are correct for install. Not working still. Thank you for the reply and for your time.
              Last edited by twitch; Mon 23rd Oct '17, 3:27pm.

              Comment


              • #8
                Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	36.7 KB
ID:	4379641

                Comment


                • #9
                  You will need to change the first value to 191...

                  criteriaid varchar(191) NOT NULL Default '',

                  Or make sure that you're using MySQL 5.5 or higher.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  Vote for your most annoying bugs.
                  I am not currently available for vB Messenger Chats.

                  Comment


                  • #10
                    I ended up installing offline with xampp and exporting the database and importing it to my live site. Everything works great. Didn't have to edit anything or change software.

                    Comment

                    Working...
                    X