Announcement

Collapse
No announcement yet.

VB 3.8.8 compatible with php 5.6?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • VB 3.8.8 compatible with php 5.6?

    I have vbulletin 3.8.8 patch level 2.

    If I upgrade php from 5.4.45 to 5.6, will it still work fine?

    VB license page says: vBulletin 3.8.7 and 3.8.8 require PHP 5.2.0+ and MySQL 4.0.16+
    but what PHP is the highest version that will work?
    Last edited by energetic-forum; Sat 2nd Dec '17, 5:58pm.

  • #2
    vBulletin 3.8x works with PHP versions up to 7.1

    It does not work with PHP 7.2

    As an aside you should upgrade to vBulletin 3.8.11

    Comment


    • #3
      Originally posted by In Omnibus View Post
      vBulletin 3.8x works with PHP versions up to 7.1

      It does not work with PHP 7.2

      As an aside you should upgrade to vBulletin 3.8.11
      Thank you!

      Is there a chart somewhere showing version and php compatibility ranges?

      In the VB member's page, it only shows the lowest version but not the highest and that would be helpful.

      Comment


      • #4
        Originally posted by energetic-forum View Post

        Thank you!

        Is there a chart somewhere showing version and php compatibility ranges?

        In the VB member's page, it only shows the lowest version but not the highest and that would be helpful.
        If there is an actual chart I am unaware of it. When you select a specific version to download the following appears:

        Notes

        vBulletin 3.8.11 requires PHP 5.6.0+ and MySQL 5.5.8+.
        vBulletin 3.8.10 requires PHP 5.5.0+ and MySQL 5.0.0+.
        vBulletin 3.8.9 requires PHP 5.3.0+ and MySQL 4.1.0+.
        vBulletin 3.8.7 and 3.8.8 require PHP 5.2.0+ and MySQL 4.0.16+.
        vBulletin 3.0.0 - 3.8.6 are not supported.

        vBulletin 4.2.5 requires PHP 5.6.0+ and MySQL 5.5.8+.
        vBulletin 4.2.4 requires PHP 5.5.0+ and MySQL 5.0.0+.
        vBulletin 4.2.3 requires PHP 5.4.0+ and MySQL 4.1.0+.
        vBulletin 4.2.2 requires PHP 5.2.0+ and MySQL 4.1.0+.
        vBulletin 4.0.0 - 4.2.1 are not supported.

        vBulletin 5.3.2+ requires PHP 5.6.0+ and MySQL 5.5.8+.
        vBulletin 5.0.0 - 5.3.1 are not supported.

        All supported versions require cURL to be installed.
        vBulletin 5.2.6+, 4.2.4+ and 3.8.10+ support MariaDB.

        Note : Only the versions below support PHP 7
        PHP 7.0 : vBulletin 5.2.5+, 4.2.5 and 3.8.11 support PHP 7.0
        PHP 7.1 : vBulletin 5.2.6+, 4.2.5 and 3.8.11 support PHP 7.1

        Comment


        • #5
          3.8.8 is not compatible with php 5.6.

          You will need 3.8.11.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            Originally posted by Mark.B View Post
            3.8.8 is not compatible with php 5.6.

            You will need 3.8.11.
            Thanks for the confirmation Mark.

            What would be helpful on the member's page as shown in the chart above is not vBulletin 3.8.7 and 3.8.8 require PHP 5.2.0+ and MySQL 4.0.16+ - because that doesn't actually show the upper range but rather: vBulletin 3.8.7 and 3.8.8 require PHP 5.2.0~5.5.0+ and MySQL 4.0.16~5.0.0 (or whatever versions) so we can actually see the latest versions each vb version works with.

            Comment

            Working...
            X