Announcement

Collapse
No announcement yet.

Attachment missing errors after another domain change

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment missing errors after another domain change

    I am having some problems displaying attachments after some domain name changes over the years.

    Forum was created on domain1.com and attachments worked great.

    Forum was changed to domain2.com and I do not remember there being any problem with attachments, but now I think attachments for domain2 worked and not domain1.

    Forum was changed to domain3.com and I realize I never changed the attachment directory. Looking at the file system, I merged the attachments directories from the domains.

    When I try to rebuild the attachment thumbnails, attachments for domain1 and domain3 work. Attachments are missing for domain2.

    Is there a right way to merge/fix this so all attachments are in just one /attachments directory?

    If it matters, I am running vBulletin 3.8 with the attachments being stored from the file system.

    In ACP, the attachments directory is correct.

    When I go to a given post that shows an attachment, and click the URL to the attachment, it gives a link to something like this:

    domain.com/attachment.php?attachmentid=17018&stc=1&d=1511240233

    Is there a way to look up this attachment to see the root of the error? And fix for all attachments affected?

    And how to prevent this from happening in the future?

    Any help would be appreciated. Thank you.
    PNW Moto
Working...
X