Announcement

Collapse
No announcement yet.

AdminCP callback image

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AdminCP callback image

    Hi,

    this is source code from /admincp/index.php?do=head in vb 3.8.x
    <<removed code>>

    What is generating this link? <img src="http://version.vbulletin.com/version.gif?v=388&amp;id=VB1234567 I want to force it to httpS://
    Last edited by Wayne Luke; Thu 19th Oct '17, 9:47am.

  • #2
    Our server will automatically redirect it to the HTTPS version. You should not need to make any changes.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Hi!
      That's the thing. It isn't redirecting. It stays http:// in source code and Mozila Firefox blocks that part in my Admin CP. My forums are completely on SSL.
      Im not feeling comfortable right now moving on another forum platform just for that. I hope there is a fix? Or there is a way I could remove that callback since you have all my URL-s alltogether with license info?
      Thanks!

      Comment


      • #4
        What version are you running?

        I don't have a vB3 install on https to check this but on my 4.2.3 installation that URL has https in front not http. I don't recall ever editing anything manually but will check.

        Code:
        <script type="text/javascript" src="https://version.vbulletin.com/versioncheck.js?v=423"></script>
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.4.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          I have posted original code from vB 3.8.8, but Wayne Luke removed it for some unknown reason to me.

          Comment


          • #6
            So it's 3.8.7.
            Are you certain it's that that is triggering the error? As there are other aspects that spring to mind.
            Go through this post, there are some file changes you can make there, these WILL generate mixed content warnings if not done:
            https://www.vbulletin.com/forum/node/4355527
            (It's for vB4 but the code is the same in vB3)
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.4.4 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Originally posted by Mark.B View Post
              So it's 3.8.7.
              Are you certain it's that that is triggering the error? As there are other aspects that spring to mind.
              Yes. It's the only link inside adminCP in http://



              Comment


              • #8
                Originally posted by karabaja2 View Post

                Yes. It's the only link inside adminCP in http://


                That doesn't necessarily mean that at all.

                The edits I linked to above are to two forms which don't show as links but do trigger the mixed content warning.
                And anyway, it isn't about links, it's about embedded content. You can have a LINK to a non-https resource without triggering mixed content.

                Can you please make those edits, then clear the browser cache and restart the browser?

                Also, please make sure you have done EVERYTHING in this guide:
                https://www.vbulletin.com/forum/arti...forum-to-https
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.4.4 Demo
                AdminAmmo - My Cloud Demo

                Comment


                • #9
                  Yes, I know. I ment embedded content. That callback is the only non SSL content inside AdminCP.

                  Originally posted by Mark.B View Post
                  Can you please make those edits, then clear the browser cache and restart the browser?
                  I have replaced every http:// to https:// inside VB folder long, long time ago. This is the only thing I cant solve. That header is generated somwhere else.

                  Comment


                  • #10
                    Originally posted by karabaja2 View Post
                    Yes, I know. I ment embedded content. That callback is the only non SSL content inside AdminCP.



                    I have replaced every http:// to https:// inside VB folder long, long time ago. This is the only thing I cant solve. That header is generated somwhere else.
                    You need to make those specific edits.

                    There should not be any requirement to edit ANY other files and this may well be contributing to the issue.

                    You should:

                    Upload a fresh set of unedited files.
                    Make the admincp edit above
                    Make sure the URL setting is correct for https in the admincp URL settings
                    Follow EVERY step in the guide I linked to

                    Doing this any other way may cause problems and is unsupported.
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.4.4 Demo
                    AdminAmmo - My Cloud Demo

                    Comment


                    • #11
                      I did it. Same thing. Embedded image still looks like:
                      <img src="http://version.vbulletin.com/version.gif?v=388

                      Comment


                      • #12
                        Originally posted by karabaja2 View Post
                        I have posted original code from vB 3.8.8, but Wayne Luke removed it for some unknown reason to me.
                        Because it contained personally identifying information that would allow someone to steal your license.

                        You will need to upgrade to 3.8.11. It uses https directly for this call. vBulletin 3.X is no longer under development so you should be running the last version anyway.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                        vBulletin 5 Documentation - Updated every Friday. Report issues here.
                        vBulletin 5 API - Full / Mobile
                        I am not currently available for vB Messenger Chats.

                        Comment


                        • karabaja2
                          karabaja2 commented
                          Editing a comment
                          OK. Thanks. But i blanked relevant data to my license.

                          I just removed this:

                          Code:
                          <?php echo ADMIN_VERSION_VBULLETIN . print_form_middle('XXXXXXX'); ?>)<?php echo iif(is_demo_mode(), ' <b>DEMO MODE</b>'); ?></a></td>
                          		<td><a href="//members.vbulletin.com/" id="head_version_link" target="_blank">&nbsp;</a></td>
                          Now it woks fine.

                        • Wayne Luke
                          Wayne Luke commented
                          Editing a comment
                          Removing it can potentially cause your installation to be listed as an unlicensed copy. While the license isn't pirated, the flag can cause unnecessary issues if a DMCA is ordered.

                      • #13
                        So what is solution? Becuse, this is the only thing it works.

                        EDIT: How about this?

                        Code:
                        <?php echo $vbphrase['admin_control_panel']; ?></b> (vBulletin 3.8.8 Patch Level 5<img src="https://version.vbulletin.com/version.gif?v=388&amp;id=XXXXXXXXX" width="1" height="1" border="0" alt="" style="visibility:hidden" />)</a></td>
                                <td style="white-space:nowrap; text-align:<?php echo $stylevar['right']; ?>; font-weight:bold">
                        Last edited by karabaja2; Fri 20th Oct '17, 9:48am.

                        Comment


                        • #14
                          The solution is to upgrade to vBulletin 3.8.11.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                          vBulletin 5 Documentation - Updated every Friday. Report issues here.
                          vBulletin 5 API - Full / Mobile
                          I am not currently available for vB Messenger Chats.

                          Comment


                          • #15
                            I've tryed. Got blank page after uploading new files.

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X