Announcement

Collapse
No announcement yet.

Profile Privacy Display Options on 3.8.11 not saving preferences

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Profile Privacy Display Options on 3.8.11 not saving preferences

    Hi all

    Profile Privacy Display Options are not saving preferences on vBulletin 3.8.11. The "Allow Users to Edit Profile Privacy" setting under User Profile Options is correctly set to "Yes" and the usergroup permission "Can Edit Profile Privacy" is also set to "Yes".

    Via /profile.php?do=privacy members can change their privacy preferences but they do not save when they return to the page at a later date. See screenshot attached.

    Centos 7
    Apache v2.4.6
    PhP 7.0.21
    MySQL 5.6.36
    vBulletin 3.8.11 vanilla (no mods)

    Files have been reuploaded and checked for suspect versions.

    Any advice appreciated.

  • #2
    This appears to be a display issue with PHP 7. It works correctly with PHP 5.6. If you look in your database, are there any issues with the profileblockprivacy table? The options should correspond as follows:

    0 - Everyone
    1 - Registered Members
    2 - Your Contacts
    3 - Your Friends

    Each user that has changed their permissions should have 8 rows in the table. If they haven't changed from the defaults, they shouldn't exist in the table.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud site. vBulletin 5 API - Full / Mobile
    Please do not PM me for support unless I specifically ask for information to be delivered that way.

    Comment


    • #3
      Hi Wayne.

      Thanks for your reply. I can set up a brand new forum using fresh vBulletin 3.8.11 files and only one user (the default admin account) and I can duplicate this error.

      Comment


      • #4
        http://tracker.vbulletin.com/browse/VBIV-16247 ?
        This is my signature.

        Comment


        • #5
          This refers to vBulletin 4.x, which is indeed fixed.

          vBulletin 3.8.11 is not fixed.

          Comment


          • #6
            Wayne.

            Some further info for you. The settings do appear to be saving even though the blocks are marked as viewable to "everyone". So this is indeed a display error in PhP 7 as you stated. Will there be a code fix for this?

            Comment


            • #7
              Originally posted by Orange20 View Post
              Hi Wayne.

              Thanks for your reply. I can set up a brand new forum using fresh vBulletin 3.8.11 files and only one user (the default admin account) and I can duplicate this error.
              Yes, I can recreate the display issue as well. The records are stored properly so the permissions should take affect. You can create a bug report in JIRA but I do not foresee future development on 3.8.11 at this time.

              According to your license, you have access to vBulletin 4. If this is a critical issue for you, you should think about upgrading to vBulletin 4.2.5.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud site. vBulletin 5 API - Full / Mobile
              Please do not PM me for support unless I specifically ask for information to be delivered that way.

              Comment

              Working...
              X