Announcement

Collapse
No announcement yet.

vBulletin 3.8.10

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin 3.8.10

    Beta 2 was released yesterday, which includes the latest security fixes.

    Note that 3.8.10 requires php 5.5.0 as a minimum, however, it is not supported on php 7.
    Baby, I was born this way

  • #2
    Really? You're forcing a PHP upgrade from 5.4 to 5.5 between Beta versions? And that includes a Security upgrade that generally needs to be fixed quickly?!?

    Seriously - this needs to work with 5.4. Really.

    Comment


    • #3
      Because PHP 5.4 is EOL

      Comment


      • #4
        Originally posted by Gary Fischman View Post
        Really? You're forcing a PHP upgrade from 5.4 to 5.5 between Beta versions? And that includes a Security upgrade that generally needs to be fixed quickly?!?

        Seriously - this needs to work with 5.4. Really.
        Yes, really.

        No, 5.4 isnt supported on this version, and isnt going to be.
        Baby, I was born this way

        Comment


        • #5
          Originally posted by Paul M View Post
          Yes, really.

          No, 5.4 isnt supported on this version, and isnt going to be.
          This is amazingly obnoxious! Right here, I asked about it, and was told 5.4 was needed for 3.8.10. So I went through the pain of rebuilding my server to support it. And now you're pulling the rug out midway through the release!

          http://www.vbulletin.com/forum/forum...4339472-3-8-10

          If it were simple to move to 5.5 or 5.6, I would do it. But it isn't. Not even a little. I run CentOS 7, which is the latest version of CentOS, and it still comes packaged with 5.4.

          Do you care at all? Even a little?
          Last edited by Gary Fischman; Fri 5th Aug '16, 7:02am.

          Comment


          • #6
            I cannot help that you find simple facts "obnoxious", but thats how it is.
            The minumum requirement for Beta 2 is 5.5.0, ranting at me about it isnt going to achieve anything.

            As to upgrading php, I run quite a few test servers, and change php around on them, its not really that hard with yum.
            Even my live server has gone from 5.3 > 5.4 > 5.5 > 5.6 in the last 18 months (all on Centos 6 btw), my php 7 server is still running centos 6.
            Baby, I was born this way

            Comment


            • #7
              Originally posted by Gary Fischman View Post

              This is amazingly obnoxious! Right here, I asked about it, and was told 5.4 was needed for 3.8.10. So I went through the pain of rebuilding my server to support it. And now you're pulling the rug out midway through the release!

              http://www.vbulletin.com/forum/forum...4339472-3-8-10

              If it were simple to move to 5.5 or 5.6, I would do it. But it isn't. Not even a little. I run CentOS 7, which is the latest version of CentOS, and it still comes packaged with 5.4.

              Do you care at all? Even a little?
              Here many and many HIGHER version php for centos product server. should very stable.
              I running centos 6.8 and php7 through this repo now.

              yum can install repo and yum install package.
              http://dl.iuscommunity.org/pub/ius/s...ntOS/7/x86_64/

              Comment


              • #8
                The nature of software development means we cannot continue to support old versions of php forever.
                In this case it is no longer practical to retain support for php 5.4 in vBulletin 3. Eventually that will happen with vBulletin 5 too. vBulletin 3 is itself very old technology and we are only updating it with minimal changes to add support for php 7. Doing so quickly and efficiently means we sometimes need to drop support for older php versions in the process - we are not going to completely recode the product to get round the incompatibilities.

                I appreciate you are disappointed with this. Attacking vBulletin staff isn't going to change anything and is a breach of the forum rules you agreed to at signup.
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
                AdminAmmo - My Cloud Demo

                Comment


                • #9
                  Originally posted by Mark.B View Post

                  I appreciate you are disappointed with this. Attacking vBulletin staff isn't going to change anything and is a breach of the forum rules you agreed to at signup.
                  I'm not "attacking staff". I'm expressing displeasure in the hopes that someone will realize that others are severely impacted by these decisions and offer some actual assistance rather than a curt "No, 5.4 isnt supported on this version, and isnt going to be."

                  Comment


                  • #10
                    Perhaps someone would be so kind as to at least let me know what type of attachments are involved in the security breach. If I can't upgrade vBulletin, at least I should be able to mitigate the risk by disabling the ability to upload that particular type of attachment, right?

                    Comment


                    • motd2
                      motd2 commented
                      Editing a comment
                      Is it so difficult to take two files from the release 3.8.10 Beta 2 and upload them?
                      includes/class_vurl.php
                      includes/class_rss_poster.php

                  • #11
                    Who is your comment directed at? If its directed at me, then the answer is "yes", because up until the time you posted that, I would have no way of knowing those are the only changes from Beta 1 to Beta 2. Are those the only files that changed? I wouldn't know because vBulletin won't publish a patch release. Also, another thread indicated that its not just files that get uploaded, but the upgrade script needs to be run as well, so there must be other changes.

                    Not sure why your snarky response was required.

                    Comment


                    • #12
                      Originally posted by Gary Fischman View Post
                      from Beta 1 to Beta 2
                      If you just need a patch for 3.8.10 Beta 1
                      http://www.vbulletin.com/forum/forum...-9-3-8-10-beta
                      see my comment http://www.vbulletin.com/forum/forum...28#post4350028

                      If you want to upgrade to 3.8.10 Beta 2 (php 5.4) make changes in includes/functions_misc.php
                      http://www.vbulletin.com/forum/forum...10#post4349810

                      If you need the correct upgrade to 3.8.10 Beta 2 - upgrade php to 5.6, then upgrade forum to 3.8.10 Beta 2

                      Comment


                      • #13
                        OK, just so we're on the same page: you're saying that if I just take those two files from the Beta 2 distro and upload them on top of Beta 1, that will fix the security issue? Just curious - how do you know?

                        Comment


                        • #14
                          It's easy. Compare patches from the other versions.

                          Comment


                          • #15
                            Originally posted by motd2 View Post
                            It's easy. Compare patches from the other versions.
                            If that's the only thing you have to go by, you're making a huge assumption.

                            Comment

                            Working...
                            X