Announcement

Collapse
No announcement yet.

Notice not displaying...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Notice not displaying...

    I have found that notices are not displaying despite trying the following:

    testing with a user who is simply a member of "Validated Registered Members" - primary group and Validated Reg Members as the group condition alone.

    Tried with persistant and dismissable on and off

    it is active

    It is html:
    Code:
    <html>
    <body>
    <p>Hi {username},</p>
    <p>blah blajh blah</p>
    <p>Best regards,<br />
      Will (stardotstar)</p>
    </body>
    </html>
    I can see the code for it still visible in my navbar:
    Code:
    <if condition="$show['notices']">
    <form action="profile.php?do=dismissnotice" method="post" id="notices">
    <input type="hidden" name="do" value="dismissnotice" />
    <input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />
    <input type="hidden" id="dismiss_notice_hidden" name="dismiss_noticeid" value="" />
    <input type="hidden" name="url" value="$return_link" />
        <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
        <tr>
            <td class="thead">$vbphrase[notices]</td>
        </tr>
        <tr>
            <td class="alt1">
                $notices
            </td>
    and also created a new style with no parent and still won't show despite having the default navbar. I do have some products but the board is on and I don't want to start turning everything off until I know that I havn't done something dumb.

    Any ideas on this?

    Will

  • #2
    Try removing the html and body tags. You can only have one html and one body tag per document. Some browsers will ignore extras, others won't and some won't even show the page with such a violation of document rules such as this.

    Then verify the conditions so that you as an administrator can see the notice. If administrators can't see the notices then you will never see it on the screen to know if it is working or not.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      Try removing the html and body tags. You can only have one html and one body tag per document. Some browsers will ignore extras, others won't and some won't even show the page with such a violation of document rules such as this.

      Then verify the conditions so that you as an administrator can see the notice. If administrators can't see the notices then you will never see it on the screen to know if it is working or not.
      Something is broken with the my modified navbar; I have removed those tags and set the display criteria to Administrators - of which I am in the primary group (#1) it only shows now with the Clear Style - or the unmodified Working Style I created.

      I must turn off hacks and so forth now I guess... Maybe adding the second row to the navbar has stuffed it up - but if you can't help since its modified I understand.

      This must have been the double tags I guess PLUS whatever issue I have with my navbar - since i had tried it with a normal user before using the clear style.

      Thanks.
      Will



      [UPDATE] I have fixed the problem - it was deprecated hack code in the navbar. [/UPDATE]
      Last edited by stardotstar; Mon 20th Apr '09, 6:19pm.

      Comment


      • #4
        Create a new style with no parent. Do your notices show up now?
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          Yes, thank you Wayne, I had a two fold problem, the criteria at first and then the stale navbar in my default style. All fixed; thank you for the suggestions!
          Will

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X