Announcement

Collapse
No announcement yet.

Upgrade vB 3.8.7 to 3.8.11

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade vB 3.8.7 to 3.8.11

    I want to upgrade php and mysql on my dedicated server, and force to upgrade my vB too, because vB3.8.7 not support php 5.4 or higher, but im not good with this procedure and dont want to put off my forums, with the risk to make some bad. I need professional assitance better, if know spanish better too. Of course a pay for the work. I have license for vB4 but have alot of plugins addons and modificated templates in my forums and no time to fix possible compatibility problems, i thinks only upgrade to vB3.8.11. Wait for offers

  • #2
    While we (vBulletin) offer a professional upgrade service it only upgrades the forum software, you would have to have PHP and MySQL upgraded first, so it does not sound like what you need.

    We do not allow solicitation of for hire work on this forum, but you can make such requests in the "Request for Paid Services" forum on vBulletin.org: https://www.vbulletin.org/forum/forumdisplay.php?f=30

    Be sure to read all sticky threads and announcements in the forum, it is "use at your own risk" and we do not monitor who may respond to you- you must do your own research on who to hire. People have been scammed before.

    If you use a web host you may inquire if they can upgrade your PHP and MySQL and then use our professional install/upgrade service.

    Comment


    • #3
      i have full control over the server, is dedicated, but if i upgrade php and mysql by myself, my forum go down, because dont support php 5.4? you can upgrade in other host and next move? without problems? i only need upgrade vb, i can upgrade php and mysql but how many time my forums must be offline?

      yes, i have bad experiences with webmaster for that ask to official vbulletin support work

      Comment


      • #4
        You have to upgrade one and then the other.

        I suggest you upgrade MySQL first, then vB, and finally PHP.

        You must do them all one after the other, and yes, your forum will have downtime, thats unavoidable [by any upgrade route].
        Baby, I was born this way

        Comment


        • #5
          I never upgrade my forum is simple work? if upgrade to vb 3.8.11 all my templates, plugins and products still working? how can check that? i dont have many time this days to fix one by one if have problems, but need to upgrade php

          Comment


          • #6
            hard work with mbstring and msqli but look all run good, upgrade msql 5.5 and php 5.6 and vb 3.8.11

            Comment


            • #7
              Good to hear.
              Baby, I was born this way

              Comment


              • #8
                Originally posted by sverdios View Post
                I never upgrade my forum is simple work? if upgrade to vb 3.8.11 all my templates, plugins and products still working? how can check that? i dont have many time this days to fix one by one if have problems, but need to upgrade php
                Templates should still work but plugins/products likely will have problems, unless they have been updated recently they may not be compatible with new versions of PHP.

                Comment


                • #9
                  Only need to update vbshout all other plugins run ok, but i have a problem, more tipical problem with spanish language xD, well i dont have many ideas about mysql, when update mysql maybe in the process can change the charset of server? now have im my language (spanish) no or appears, php charset are the same of the spanish .xml uploaded, iso-8859-1, but charset of mysql server is utf-8, that can be a problem? how can fix now

                  Comment


                  • #10
                    in the config.php file look for the line

                    PHP Code:
                    // $config['Mysqli']['charset'] = 'utf8' 
                    try changing it to

                    PHP Code:
                    $config['Mysqli']['charset'] = 'utf8' 
                    or

                    PHP Code:
                    $config['Mysqli']['charset'] = 'latin1' 
                    See if either works. If they don't, change it back to default.

                    Comment


                    • #11
                      I try with you sugestion and dont work neither

                      the strange, if i create a new thread and put a tittle with or accent strange symbols appear, in the body of the post the same, if edit after in the body appear fine or accent, not in tittles errors continue.

                      I restart in every change mysql and apache services, still the problem with charset

                      Comment


                      • #12
                        update, i change my php.ini and edit charset from utf-8 to iso, and worst, change to latin1_swedish_ci my database have this charset, well some prodcuts create tables in utf, but not problem, now accents and appear fine, but all old post and tittles continue with problem, any way to rebuild? rebuild forum optimize tables but not rebuild or fix errors in post

                        Comment


                        • #13
                          Originally posted by sverdios View Post
                          rebuild forum optimize tables but not rebuild or fix errors in post [/I]
                          Those functions have nothing to do with the display. Optimizing tables will only clear out deleted data. Repair doesn't do anything unless the table is crashed and inaccessible. Neither performs any operations on how the table stores data.

                          1) All tables and all fields within those tables should be using the same character set and collation. You need to choose which one works best for you. There may be old content that needs to be edited after you make changes like this and you should back up your database beforehand.
                          2) You need to have the iconv and mbstring PHP libraries installed for character translations to work properly.
                          3) If you're using UTF-8 characters, you need to tell vBulletin to use UTF-8 in the AdminCP under Languages -> Languages Manager.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                          vBulletin 5 Documentation - Updated every Friday. Report issues here.
                          vBulletin 5 API - Full / Mobile
                          I am not currently available for vB Messenger Chats.

                          Comment


                          • #14
                            Is there any way I can upgrade my 3.8.7 to the latest 3.8x? I am willing to pay, but I don't see the option to do this. I don't think it's necessary to pay for vB5 if I want to stay on 3.8x. My forum is practically dead, but I don't want to close it down, yet I need to upgrader my PHP for security purposes and my current vB won't run on it. That is my dilemma...
                            Marc James
                            Sports Central Beyond the Scores
                            Sports Central Message Boards

                            Comment


                            • #15
                              If you log into your Member's Area, there should be a link to upgrade your vBulletin 3.X license to a vBulletin 4 license for $149.00. If you do that, you can upgrade to the latest vBulletin 3.X version or the latest vBulletin 4 version.
                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                              vBulletin 5 Documentation - Updated every Friday. Report issues here.
                              vBulletin 5 API - Full / Mobile
                              I am not currently available for vB Messenger Chats.

                              Comment

                              Working...
                              X