No announcement yet.

Upgrading vBulletin 3.8 to work with SSL (https) website

  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrading vBulletin 3.8 to work with SSL (https) website

    I have been running a vBulletin 3 website for many years and I now want to use it with an SSL certificate so that the website will work properly with an https:// URL.

    I have installed the SSL certificate and changed all the internal URLs in settings to https, yet there are lots of problems.
    For example, when using the advanced editor, none of the buttons (Bold, etc) can be used, no reaction. If you use the website in http: mode, it works perfectly.
    Also, I never get the "Secure" message in Chrome for example. I really want this to work in SSL, but I do not know how to solve these problems.

    Can anyone help. The forum in question is https://www,

    I did try a fresh install in a test forum ( with nothing added and the advanced editor did not freeze, there. However, the "Secure" message was also not shown.
    Is this version of vBulletin not compatible with SSL? Is there a way of fixing this? Could it be CSS problems causing this?
    Last edited by Peter Walker; Sun 30th Apr '17, 7:47pm.

    Peter Walker

  • #2
    Please follow our guide in the first instance:

    TalkNewsUK - My vBulletin 5.4.4 Demo
    AdminAmmo - My Cloud Demo


    • #3
      I have followed those instructions and I had missed the final step of updating the styles. However, the advanced editing still does not work (clicking on B for bold, etc. does not cause any reaction) and have lots of members with login problems. Many are complaining about being told their posts have to be at least 10 characters long when their posts are considerably longer. My own tests show this error happens with IE and FireFox, yet not with Chrome.
      Others cannot read their PMs.
      What else can I do?
      Last edited by Peter Walker; Tue 2nd May '17, 5:13am.

      Peter Walker


      • #4
        I have now found the answer to this issue:
        vBulletin Options -> vBulletin Options -> Server Settings and Optimization Options
        Right at the bottom, there is the option "Use Remote YUI" and it was set to Yahoo! Other options are "None" and "Google." Yahoo does NOT support SSL. Set this to Google. and save.

        Peter Walker


        Related Topics