Announcement

Collapse
No announcement yet.

Server migration: vB 3.8.9 to vB3.8.10 and differing PHP versions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server migration: vB 3.8.9 to vB3.8.10 and differing PHP versions

    Hi,

    The hosting company I use wants to migrate my site from a server running PHP 5.3.3 to one running PHP 5.7. My forum is currently running vBulletin v3.8.9 Patch Level 1.

    I realise according to the vB server specs given in the download area for each version that I can't do the vB upgrade to 3.8.10 prior to the server move (minimum spec is PHP 5.5+, I'm on 5.3), but what I can't figure out is whether 3.8.9PL1 will run on PHP 5.7 or not (the spec just says PHP5.3+ with no upper limit given), i.e. how do I actually do this? I guess my question is does PHP 5.7 actually break vBulletin 3.8.9PL1, and if it does how do I proceed and install 3.9.10?

    Thank you in advance for any help.

    Tony.

  • #2
    Hey Tony,

    If you are using Plesk or cPanel then it is easy to choose different PHP version for each website (domain name) with just some clicks.



    Web Hosting Forum - Learn web hosting and offering your web hosting plans for free!

    Comment


    • #3
      There is no PHP 5.7 version. It would be PHP 5.6 or PHP 7.X. This distinction is important. If they are going to use PHP 5.6, on your site then you should be okay and your site should transfer properly.

      If they are installing PHP 7.X, you can still migrate the site. However, you will need to upgrade to 3.8.11. The site won't work properly until the upgrade is done.

      Also, don't confuse PHP versions with MySQL versions. There is a MySQL 5.7.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud site. vBulletin 5 API - Full / Mobile
      Please do not PM me for support unless I specifically ask for information to be delivered that way.

      Comment


      • #4
        Thank you, that clarifies it nicely. Must be some confusion at the hosting company as they certainly just asked me about "PHP 5.7" as I'd already told them I didn't want to go to PHP 7 until the final release of vB3.8.11 is out and that I needed 5.5+ to install vB3.8.10.

        Comment


        • #5
          So just to really nail this process down to the point I don't mess it up: to move my 3.8.9PL1 site to a PHP 7.x server, I'd turn the site off in the AdminCP, let the server company migrate it as-is to the new PHP 7 server, upload vB 3.8.11 package and run the upgrade script (I assume I can ignore 3.8.10), and then finally turn the site back on?

          Comment


          • #6
            That will work.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud site. vBulletin 5 API - Full / Mobile
            Please do not PM me for support unless I specifically ask for information to be delivered that way.

            Comment


            • #7
              Thank you.

              Comment

              Working...
              X