Announcement

Collapse
No announcement yet.

vBulletin 3.8 won't install correctly.

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin 3.8 won't install correctly.

    Hello,

    I'm having issues trying to install vBulletin. vB 3/4/5 all seem to just break. vBulletin 5 breaks after installation (admincp won't show anything, and the main forums just look awful with no images showing or anything.) vB 3 and 4 have errors during the initial installation.

    https://friendstein.org/legacybb/install/install.php

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; vB_Database has a deprecated constructor in /home/friends6/public_html/legacybb/includes/class_core.php on line 78

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; vB_Datastore has a deprecated constructor in /home/friends6/public_html/legacybb/includes/class_core.php on line 1251

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; vB_Input_Cleaner has a deprecated constructor in /home/friends6/public_html/legacybb/includes/class_core.php on line 1510

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; vB_Registry has a deprecated constructor in /home/friends6/public_html/legacybb/includes/class_core.php on line 2346

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; vB_Session has a deprecated constructor in /home/friends6/public_html/legacybb/includes/class_core.php on line 2647

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; vB_Shutdown has a deprecated constructor in /home/friends6/public_html/legacybb/includes/class_core.php on line 3171

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; vBulletinHook has a deprecated constructor in /home/friends6/public_html/legacybb/includes/class_hook.php on line 27

    I tried ignoring the errors but it ends up that after submitting a new thread it will show a 404 error.
    I want to use vB 3.8.10 preferably.
    My Host is on PHP 7.1x
    MySQL 10

    Thanks.

  • #2
    You need vB 3.8.11 for php 7.

    Otherwise, for 3.8.10 you will need php 5.5. or 5.6.

    Your vB5 issues sound to me like you didn't rename htaccess.txt to .htaccess. Either that or rewrite rules aren't working on your server.

    Also...if you are experimenting and switching between vB3 and vB5, remember that you can't have both sets of files in the same forum server...so if you are using vB3 or vB4, and decide to try vB5, you MUST remove ALL vB3 or vB4 files from the folder, otherwise vB5 will not work. The same applies in reverse.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.4.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Originally posted by Mark.B View Post
      You need vB 3.8.11 for php 7.

      Otherwise, for 3.8.10 you will need php 5.5. or 5.6.

      Your vB5 issues sound to me like you didn't rename htaccess.txt to .htaccess. Either that or rewrite rules aren't working on your server.

      Also...if you are experimenting and switching between vB3 and vB5, remember that you can't have both sets of files in the same forum server...so if you are using vB3 or vB4, and decide to try vB5, you MUST remove ALL vB3 or vB4 files from the folder, otherwise vB5 will not work. The same applies in reverse.
      Is vBulletin 3.8.11 even stable? It looks like it isn't updating as much.

      Comment


      • #4
        Originally posted by The Guy View Post

        Is vBulletin 3.8.11 even stable? It looks like it isn't updating as much.
        It's technically still a beta but it's fine to run it.
        It mainly contains only php 7 compatibility changes.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.4.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Originally posted by Mark.B View Post

          It's technically still a beta but it's fine to run it.
          It mainly contains only php 7 compatibility changes.
          Thank you, looks like it works so far.

          Kind of a long shot, bur any chance on exactly when the stable release is due?

          Comment


          • #6
            Originally posted by The Guy View Post

            Thank you, looks like it works so far.

            Kind of a long shot, bur any chance on exactly when the stable release is due?
            Should be in the next couple of months.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.4.4 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              So how do I get my hands on 3.8.11? Do I really have to buy 5x just to get a minor update on 3x?
              Marc James
              Sports Central Beyond the Scores
              Sports Central Message Boards

              Comment


              • #8
                I've answered this in one of the other threads. Please only post a question once, we won't get to it any faster if it's posted all over the place.
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.4.4 Demo
                AdminAmmo - My Cloud Demo

                Comment

                Related Topics

                Collapse

                Working...
                X