Announcement

Collapse
No announcement yet.

Can not sign up new users ?? HELP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can not sign up new users ?? HELP

    Hi

    I have resently upgraded to 3.8.1. The upgrade seem to go smoothly apart from one thing.

    When I new users tries to register they aren't able to add anything into the "User Name" field. It's as if JS has been used to stop text being added when you move the cursor and try and select another field the following error appears "Please complete the required field "Username". NB at no point have i tired to submit the form.

    If I go back to the User Name field the same thing happens. There is no way for the users to type anything into the username field.

    Please help as currently no new users can sign up to the forum.

    PS We have no registration mods or hack at all.

  • #2
    I do not see how that is possible with no add-ons or modifications at all.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);


    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Then make this the default style.

    Admin Control Panel -> vBulletin Options -> Style & Language Settings -> Default Style

    Finally empty your browser cache, close all browser windows then try again. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks, I have tried all of that and still exactly the same fault. i have tested this on IE firefox on 2 different computers with the same result.

      You can see the fault by trying to register here
      http://www.grassrootscoaching.com/forum/

      Thanks in advance

      Comment


      • #4
        I get Please complete the required field "Username".

        Have you tried without that skin?.. using the default VB skin.
        Simple Straight Forward EU cPanel vBulletin Web Hosting Provider.

        Comment


        • #5
          Yes I have tried it with the default skin, same error.

          I have now switched to the default skin so if you try the link now it will give the same error message from the default VB skin.

          Thanks

          Comment


          • #6
            try disabling the hook system
            Simple Straight Forward EU cPanel vBulletin Web Hosting Provider.

            Comment


            • #7
              Actually you have not followed those instructions because you are still running vBSEO.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                I had followed the instructions and disabled the hooks as requested but as It didn't make any difference I turned them back on.

                I have now disabled the hooks again and left it so you can see disabling the hooks made no difference.

                I have also set a new style built from the default style template.

                If you check the forum out now you will see that the problem is still there no users can sign up at http://www.grassrootscoaching.com/forum/

                One other thing i have also noticed is I am unable to add anthing into the Refferer box, this behaves in the same way as the username box apart from there is no error message.
                Last edited by powder99; Tue 10th Feb '09, 3:11am.

                Comment


                • #9
                  Fill out a support ticket at:

                  http://members.vbulletin.com/members...ontactform.php

                  Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Gives an error for me saying your username cannot be longer than 0 characters, which is your problem...but the form works fine on my end, but that's why people can't register obviously. -.-
                    > Follow this link for the CHEAPEST Domain Name Registration - Domain Transfers Are Even Cheaper! :)
                    WoW Accounts, FFXI Accounts, Aion Accounts, FFXIV Accounts, MMORPG Market

                    Comment


                    • #11
                      I know this is an old thread but something similar happened to me and the issue was the PHP version that was not compatible with our vBulletin version. I changed a setting to use a different PHP version and the issue was resolved.

                      After having that issue we updated to the latest version of vBulletin

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X