Announcement

Collapse
No announcement yet.

Attachment Bug when posting in Group / Forum

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment Bug when posting in Group / Forum

    I've tried this many times. After I've uploaded a photo through upload attachment feature, if I choose the "Insert: large or fullsize", everything is fine. But if I choose the small, medium and thumbnail, bugs will appear sometimes like shown in the images below:

    This image shows when I've just uploaded the photo (no problem here): Click image for larger version  Name:	Screen Shot 2017-05-14 at 2.58.34 AM.png Views:	1 Size:	57.4 KB ID:	4370012



    This is when I click on the "insert: medium, small or thumbnail" into the post. The image not showing correctly, and after posting the image is not showing up as well, just a broken image shown in the preview. Click image for larger version  Name:	Screen Shot 2017-05-14 at 2.59.00 AM.png Views:	1 Size:	32.6 KB ID:	4370013


    As shown here: https://www.fanschats.com/fan-clubs/...2-wooden-chest

    How can I solve this problem? I'm currently using vbCloud, maybe this issue will be solved in the next update automatically? Hope that this issue can be solved as soon as possible. This is quite a big problem for us as image feature is important in our forum. And, a lot of my posters also have this exact issue, all of them posted broken images, and eventually they gave up posting images instead. Please have a look into the problem. Thanks.
    Last edited by ljianyih; Sat 13th May '17, 10:38am.

  • #2
    If you insert full size and then double-click the inserted image to change the size, what happens?

    If you open the Rich text menu, by pressing the A button and insert an image using the insert image icon, what happens?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      I've tested this "If you insert full size and then double-click the inserted image to change the size, what happens?" and the process and result is shown below.

      This image shows when I insert full size. Everything is fine.
      Click image for larger version

Name:	Screen Shot 2017-05-17 at 1.49.47 PM.png
Views:	4
Size:	572.7 KB
ID:	4370253


      This image shows when I double-click the inserted image to change the size to small.
      Click image for larger version

Name:	Screen Shot 2017-05-17 at 1.50.03 PM.png
Views:	4
Size:	43.8 KB
ID:	4370254

      This image shows the result after I double-clicking the inserted image to change the size to small, and click OK.
      Click image for larger version

Name:	Screen Shot 2017-05-17 at 1.50.13 PM.png
Views:	2
Size:	25.9 KB
ID:	4370255


      Again, I tried changing the size to thumbnail, small, medium, large, and full size. This time only "small" size has the problem, others are fine, but sometimes medium and thumbnail have the same issue as well. (Just large and full size always fine).

      And also, I tried this issue in this forum (official vbulletin forum) here, and none of the issue exists. As we are just using the default vbCloud with latest vbulletin version without adding any mods or anything (I didn't really change much for any of the forum default setting).

      Comment


      • #4
        After I've posted the large image in the example above, where everything is fine, I edit the post and try to change the size again. But this time, "small", "medium" and "thumbnail", and "icon" sizes show the broken image, except for the "large" and "full" sizes (which are always fine).


        "If you open the Rich text menu, by pressing the A button and insert an image using the insert image icon, what happens?"
        - This produces exactly the same issue (as the example shown above). The main problem from my testing, is the image resizing problem, specifically for "thumbnail, small and medium" sizes in this case.
        Last edited by ljianyih; Tue 16th May '17, 9:20pm.

        Comment


        • #5
          I haven't been able to recreate the issue on 5.3.0. What settings do you have for your image sizes under Settings -> Options -> Message Attachment Options?
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
          vBulletin 5 Documentation - Updated every Friday. Report issues here.
          vBulletin 5 API - Full / Mobile
          I am not currently available for vB Messenger Chats.

          Comment


          • #6
            Here is the screenshot showing the image sizes:
            Click image for larger version

Name:	Screen Shot 2017-05-19 at 10.56.59 PM.png
Views:	7
Size:	32.0 KB
ID:	4370445

            Comment


            • #7
              Do you have a link to unaltered images that can be used to test?
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
              vBulletin 5 Documentation - Updated every Friday. Report issues here.
              vBulletin 5 API - Full / Mobile
              I am not currently available for vB Messenger Chats.

              Comment


              • #8
                Aside from the icon, those appear to be the default sizes. I cannot recreate the issue here:
                https://www.vbulletin.com/forum/foru...453-image-test

                It may be that your images are more difficult to resize and the process fails.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                vBulletin 5 Documentation - Updated every Friday. Report issues here.
                vBulletin 5 API - Full / Mobile
                I am not currently available for vB Messenger Chats.

                Comment


                • #9
                  Do you have a link to unaltered images that can be used to test?
                  Actually we've tested a lot of images (posted for months), and it's not about the images problem.

                  From all of our testing, it appears that our forum https://www.fanschats.com actually has a lot of bugs (image resizing is one of the bigger issue to us), which other vbulletin forums on vbCloud don't really have. We mainly just use the default system setting without any major changes, and we didn't add or install any mods at all.

                  One of the reasons we can think of, is maybe because we bought the vbulletin (vbulletin 5) few years ago and stopped everything for quite some time, and we get back the domain, forum and everything few months ago. Maybe the updates for vbCloud on our forum are not performed thoroughly during these "unavailable" period of time.

                  We tried to send the support tickets, but haven't actually receive any response for about 5 days, and for the previous support tickets doesn't really fix the problems for our forum. We actually just want our forum to function normally just like all other forums on vbCloud.

                  Is there any good suggestion? Like reformatting the whole forum or other better solution? (Sorry for asking all these here, but actually you are one of the best supports, the support tickets we sent doesn't really get the real support we want, which is to fix our forum bugs and issues.)
                  Last edited by ljianyih; Fri 19th May '17, 11:33pm.

                  Comment


                  • #10
                    I can't reproduce the issue without access to the images that you're using. I am trying to help and all you're doing is arguing. Sure, we can delete your entire site and you can start over. However, that really isn't a solution is it?
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                    vBulletin 5 Documentation - Updated every Friday. Report issues here.
                    vBulletin 5 API - Full / Mobile
                    I am not currently available for vB Messenger Chats.

                    Comment


                    • #11
                      I'm sorry, was trying to explain the situation. For example, we tried these images:

                      https://upload.wikimedia.org/wikiped...emo_Banana.png.
                      https://www.uncruise.com/application...nsion-hero.png
                      http://sequencewiz.org/wp-content/pl...on-gallery.png

                      For most of the cases, large size and full size have no problem when resizing, but small size and medium produces broken images. And the bug is mainly for png images. (you can also simply try on our forum if necessary.)

                      Again, sorry, if you need more images to test I can find more though.

                      Comment


                      • #12
                        Just replicated this on my own demo cloud site with the third image, in the third post in this thread:
                        https://www.adminammo.com/forum/site...ttachment-test

                        We'll see if we can find out what's causing this.
                        MARK.B | vBULLETIN SUPPORT

                        TalkNewsUK - My vBulletin 5.5.2 Demo
                        AdminAmmo - My Cloud Demo

                        Comment

                        Related Topics

                        Collapse

                        Working...
                        X