Announcement

Collapse
No announcement yet.

Placing a user under temporary moderation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Placing a user under temporary moderation

    Hi, I am a new VB admin working on setting infractions on a new forum (using VB cloud V 5.2.2) I need to be able place mis-behaving users under moderation i.e. they can make posts but these are placed in the moderation queue pending authorisation, only after which they will be seen by other users.
    I have setup a user infraction group, called 'moderated users' I know this part works as the user title changes in line with the points rule. Within the group I have set Post / Topic Permissions - Follow Channel Moderation Rules to NO (since a no overrides a yes) but the user can continue to post as normal.

    Is there another setting I need to change? Alternatively is there anything else I could do which would achieve the same aim?
    Thanks
    -Andy
    Last edited by Dapol_andy; Wed 8th Jun '16, 1:54pm. Reason: clarified

  • #2
    There are actually two permissions to control this. (I don't know why that is...) Make sure that Require Moderation for Posts is set to Yes as well.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Thanks for the help, it was set to No.
      But its curious. When I set 'Require Moderation for Posts' to Yes and save, it resets back to No.

      I then went through channel manager and set both permissions up on each channel for the moderated group, but the group permission 'Require moderation for Posts' still resets to No. Also despite both permissions being set in the
      channel permissions for that group being set to enforce moderation, the user can still post.

      I'm fairly sure I'm missing something obvious here, so will sleep on it!
      Last edited by Dapol_andy; Thu 9th Jun '16, 1:37pm. Reason: Checked user channel permissions and reported back.

      Comment


      • #4
        I've a feeling that's a bug in the display only - the permission saves but when you view the page it looks like it hasn't but can't find the Bug Report for that at the moment...
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - Highlight the correct navigation tab when you are on a custom page
        - "Quick Route" Interface...
        - Allow to use custom icons for individual forums

        Comment


        • #5
          When I set 'Require Moderation for Posts' to Yes and save, it resets back to No
          Trevor - FWIW this is the issue that I mentioned in my support ticket but couldn't successfully replicate.

          Comment


          • #6
            Macro Man - regarding your issue; is 'Require Moderation for Posts = Yes' being honoured so it's just the displayed value resetting, or are actual invoked permissions also stuck at 'No' ?
            I've tried several times to make this work including setting usergroup level permissions on the channel, but users can still post immediately.

            Comment


            • #7
              Dapol_andy for me I think the setting did actually take effect (as Trever suggested) but the front end just wasn't updating so it appeared as if the setting hadn't saved.

              Comment


              • #8
                I must have something incorrectly configured, but just cannot find it - getting a little frustrating as this is in our view essential functionality for any public board.

                I have setup a new infraction group (moderated users')', and set the permissions:
                'Require Moderation for Posts' to Yes and Follow Channel Moderation Rules to NO - user can still post normally

                I have also setup user channel permissions with the same values - user can still post normally.

                If I manually set a users primary usergroup as 'moderated users', when the user makes a post the page refreshes and the post vanishes. It does appear in the topic as unapproved after 2-3 minutes but does not show in the moderation queue (Admincp/home/Posts to Moderate = 0)

                If I click on admincp/home/Posts to Moderate [view] then I get this error: Invalid Page URL. If this is an error and the page should exist, please contact the system administrator and tell them how you got this message.

                I'm starting to think there's something a little more wrong here than a configuration issue?
                Last edited by Dapol_andy; Sat 11th Jun '16, 7:27am. Reason: discoverd posts show up after delay period.

                Comment


                • #9
                  Please open a support ticket so someone can log into your account and view the settings.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X