Announcement

Collapse
No announcement yet.

some image errors since upgrade to php 5.5

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • IggyP
    started a topic some image errors since upgrade to php 5.5

    some image errors since upgrade to php 5.5

    trying to troubleshoot a couple basic functionality issues before putting george to work with some heavy lifting...anyone can help with this pls pls?

    so basically....i was using apc...upgraded to php 5.5 which of course broke apc settings and for vbulletins config.php file

    i now have zendopcache and apcu installed, but have commented the whole cache section out for now...

    my main goal is to fix the image issue just for now so i can keep working until more intensive server tuning can be done.

    at first i noticed some uploaded attachments were displaying as broken images, but now i am only getting this error

    "PHP Error: The function exec() has been disabled. "

    i ran the upload diagnostic in vb acp and it said no error reading...

    any ideas to resolve this?

    also wondering if php 5.6 is officially supported atm

    thank you,
    Iggy
    Last edited by IggyP; Tue 10th Nov '15, 12:04am.

  • Wayne Luke
    replied
    "PHP Error: The function exec() has been disabled. "
    This is a server configuration issue. You will need to enable this function or use the internal GD library. We have no control over this.

    Leave a comment:


  • Set3sh
    replied
    Hello,

    Feel free to contact me when you need that full proper configuration.

    Kind regards,
    George.

    Leave a comment:


  • IggyP
    replied
    oh hey...thanks yeah, by now im on php 5.6 and gearing for php7 but it is interesting to note because i was mention imagemagick in this topic and now i have noticed there is an issue with EA4 (multiphp) and imagemagick and custom php.ini......tried for some time with host to allow my custom php.ini AND imagemagick but ended up having to chose the custom php.ini and go with GD as it seems EA4 is not ready for that support? perhaps there is a solution, but we could not find it

    btw, i am still looking forward to a full proper configuration, hopefully soon after this 5.2.1 and the php7 and such

    Leave a comment:


  • Set3sh
    replied
    Hello,

    Check php.ini and remove "exec" from disabled_functions.
    Moreover please ensure your php version was compiled with gd-image support.

    Kind regards,
    George.

    Leave a comment:


  • IggyP
    replied
    oh ya der.......so the php error was due to an imagemagick configuration error and has been resolved...so im least back to the broken image issue hmm

    Leave a comment:

Related Topics

Collapse

Working...
X