Announcement

Collapse
No announcement yet.

Help changing my logo's link from forum's home to the main website

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help changing my logo's link from forum's home to the main website

    Hi,
    I have a custom theme and dont have the knowledge to fix this simple thing.
    If I'm use Vbulletin's Default stock theme I can change the logo link by editting the template header as shown on the attached picture.
    But for the custom theme there is no code here to control the logo's hyper link. It seems that this is controlled by a forum.php file.
    I've spent two sets of about 10+ hours messing around and now I've just dropped the towel and need some help.

    Regards,

    PS. I'm using VB 4.2.2

  • #2
    The answer is in the two images, right in front of you. Look in the first image for the term titleimage. That's the code for the logo for the default style. Take it, remove whats not needed, and add it to your template. 10 hours is a long time, rest up first.

    Comment


    • #3
      @infopro, Thanks for the info.
      I dont know about coding at all and couldn't make it work right with the information you gave me, my fault.
      I ended up with a second logo picture on the top bar which does indeed link to the right place.

      Here is the code from the default style if any body could tune it for me, thanks.

      <div class="above_body"> <!-- closing tag is in template navbar -->
      <div id="header" class="floatcontainer doc_header">
      <vb:if condition="$stylevar['titleimage']"><div><a name="top" href="http://www.advancedreworks.com" class="logo-image"><img src="{vb:stylevar titleimage}" alt="{vb:rawphrase x_powered_by_vbulletin, {vb:raw vboptions.bbtitle}}" /></a></div></vb:if>
      <div id="toplinks" class="toplinks">
      <vb:if condition="$show['member']">
      <ul class="isuser">
      <li><a href="login.php?{vb:raw session.sessionurl}do=logout&amp;logouthash={vb:raw bbuserinfo.logouthash}" onclick="return log_out('{vb:rawphrase sure_you_want_to_log_out}')">{vb:rawphrase log_out}</a></li>
      Last edited by drichiez; Sun 18th May '14, 9:18pm.

      Comment


      • #4
        Originally posted by drichiez View Post
        @infopro, Thanks for the info.
        I dont know about coding at all and couldn't make it work right with the information you gave me, my fault.
        I ended up with a second logo picture on the top bar which does indeed link to the right place.

        Here is the code from the default style if any body could tune it for me, thanks.

        <div class="above_body"> <!-- closing tag is in template navbar -->
        <div id="header" class="floatcontainer doc_header">
        <vb:if condition="$stylevar['titleimage']"><div><a name="top" href="http://www.advancedreworks.com" class="logo-image"><img src="{vb:stylevar titleimage}" alt="{vb:rawphrase x_powered_by_vbulletin, {vb:raw vboptions.bbtitle}}" /></a></div></vb:if>
        <div id="toplinks" class="toplinks">
        <vb:if condition="$show['member']">
        <ul class="isuser">
        <li><a href="login.php?{vb:raw session.sessionurl}do=logout&amp;logouthash={vb:raw bbuserinfo.logouthash}" onclick="return log_out('{vb:rawphrase sure_you_want_to_log_out}')">{vb:rawphrase log_out}</a></li>
        That is the target url for your logo, change it to whatever you like.
        Last edited by donald1234; Mon 19th May '14, 12:53pm.

        Comment


        • #5
          Pardon me if I caused any confusion but.
          The last code I posted is from the default Style (just to show that it works the way I want it with this style). The problem I'm having is with my custom style which dont have this code in this field. It only has what is shown on picture number 2.
          Infopro advised I took the code from the default style, remove what is not needed and it should work. Well I dont know what is needed or not or the right configuration/adaptation for the default's style's code to work on my custom style.

          Thx

          Comment


          • #6
            The code for the custom theme must exist, it's just you are not finding it. Ask the author of your theme how to edit your logo image, it's impossible for us to guess.

            Comment


            • #7
              Doesn't look like he's supporting this product anymore. He's been unresponsive for a long while now.
              The attached picture seems to show that the link points to a forum.php file. But I dont see anything on that file that I could recognize as having to do with the logo link. So I guess there are other parties involved in the process, but I have no idea.

              Comment


              • #8
                Do you have a link to your forum so I can take a look at the page source? that photo is a bit small to read.

                Comment


                • #9
                  Sure, I appreciate it.
                  http://advancedreworks.com/Forum/forum.php

                  PS. If you click on the image, and then right click on the mid-sized image that pops up and select view image, you'll be able to see the full image size.

                  Thx

                  Comment


                  • #10
                    Ok if you right click your home page and choose "view page source" and scroll down to line 226 you will see this line
                    Code:
                    <div style="float: left; width: 30%;"><a href="forum.php?s=4b3c5222a17d87986db72a9fd9aa0335" class="logo-image"><img src="images/tf_ideal/red/misc/logo.png" alt="Advanced Reworks Forums - Powered by vBulletin" /></a></div>
                    so go to your admincp and go to Styles and Templates -> Search in Templates -> Search in Style select the style and search for something hopefully unique to that line eg logo-image that should take you to the correct template. and put your full url instead of this home page url forum.php?s=4b3c5222a17d87986db72a9fd9aa0335

                    Comment


                    • #11
                      @donald1234, I appreciate you trying to help but this looks like it ain't gonna happen. I'm only in my second week into the vbulleting world and I'm already getting accustomed to things, even the most basic ones, being far more difficult to accomplish than they should.
                      My search function is very sensitive or should i say useless. For example if I search forum.php it just dont work and takes me to the style manager start page. If i search for .php it brings tenths of results, of course. If I search for forum, same things, lots of results. So you see that with this limitations is impossible to get a search result of the code or any useful part of it.

                      Thx.

                      Comment


                      • #12
                        Have you tried style manager, then after selecting your custom style from the drop down choose edit template, then click on header

                        Comment


                        • #13
                          Yeah, that's what I described on the first post. Two pictures show the difference that exists between the default style and the custom style. The custom style dont have anything in the header that seems to be where this function is taking place.
                          I tried copying that code from the default style onto the custom style and ended up with a second ghostly looking logo on the menu bar which pointed to where i want it to.

                          Comment


                          • #14
                            I am not familiar with that style, I presume the header code unusually is in a template other than the header, your best chance of finding it is by doing searches for keywords the above line and keep searching till you find it. Making sure you are searching in that styles templates and not the default.

                            Comment


                            • #15
                              Ok. I'll do that. Thanks for the help Donald.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X