Announcement

Announcement Module
Collapse
No announcement yet.

Your submission could not be processed because a security token was missing or ???

Page Title Module
Move Remove Collapse
This topic is closed.
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Your submission could not be processed because a security token was missing or ???

    Hi... using latest version a user asked me about their password, i check their account via admin and decided to send them a password reminder which resulted in a white screen informing me >

    Your submission could not be processed because a security token was missing or mismatched.

    please advise, cheers

  • #2
    Did you make sure to revert your templates? Do you have any modifications running that would affect you sending the password? You may want to take a look at this thread regarding all forms being used in the newest versions of vb: Implementing CSRF Protection in modifications

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      Originally posted by U2Lynne View Post
      Did you make sure to revert your templates? Do you have any modifications running that would affect you sending the password? You may want to take a look at this thread regarding all forms being used in the newest versions of vb: Implementing CSRF Protection in modifications
      No, it's a bug.

      Fix is here:


      In includes/adminfunctions.php find:
      Code:
      echo "<input type=\"hidden\" name=\"adminhash\" value=\"" . ADMINHASH . "\" />\n";
      Add below:
      Code:
      echo "<input type=\"hidden\" name=\"securitytoken\" value=\"" . $vbulletin->userinfo['securitytoken'] . "\" />\n";
      It'll be fixed in the next release.
      MARK.B | vBULLETIN SUPPORT
      NEW vBulletin 5 Tutorials

      Comment


      • #4
        Originally posted by Mark.B View Post
        No, it's a bug.
        I just saw that and was coming back to this thread to post the link. Thanks.

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools &lt;- awesome site for html/css help

        Comment


        • #5
          Yes thank you both for the help, cheers

          Comment


          • #6
            I checked and I already have that line of code

            echo "<input type=\"hidden\" name=\"adminhash\" value=\"" . ADMINHASH . "\" />\n";
            echo "<input type=\"hidden\" name=\"securitytoken\" value=\"" . $vbulletin->userinfo['securitytoken'] . "\" />\n";

            still getting the error .. Ideas ??

            Comment


            • #7
              Originally posted by Total666 View Post
              I checked and I already have that line of code

              echo "<input type=\"hidden\" name=\"adminhash\" value=\"" . ADMINHASH . "\" />\n";
              echo "<input type=\"hidden\" name=\"securitytoken\" value=\"" . $vbulletin->userinfo['securitytoken'] . "\" />\n";

              still getting the error .. Ideas ??
              I didn't have it by the looks of it... i added it and it worked fine. I'm not sure what your problem is...

              Comment


              • #8
                i have same problem
                if i do search

                Message
                Your submission could not be processed because a security token was missing or mismatched.

                If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

                my forum version 3.7.0 rc4

                can you help me ??

                Comment


                • #9
                  Originally posted by beyefendi View Post
                  i have same problem
                  if i do search

                  Message
                  Your submission could not be processed because a security token was missing or mismatched.

                  If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

                  my forum version 3.7.0 rc4

                  can you help me ??
                  Hi, did you try the edits?

                  Comment


                  • #10
                    yes.
                    but same problem

                    Your submission could not be processed because a security token was missing or mismatched.

                    If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

                    Comment


                    • #11
                      sorry to hear that... I'm on the 3.6 series, yours sounds like a bit more is involved, don't worry the guys here are very good you'll get a quick fix in time...

                      Comment


                      • #12
                        beyefendi it would be in your best intrest to create your own thread on this issue you are having.
                        You can click on this button and add relevant information about what errors you are receiving

                        Comment


                        • #13
                          hi,

                          when i upgrade 369 to 3610 i have that error too. please help to we.

                          Comment


                          • #14
                            See this:

                            http://www.vbulletin.com/forum/showthread.php?t=268610

                            If you have ny further problems then please start your own thread with all the relevant details. Thank you.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Your submission could not be processed because a security token was missing or mismatched.

                              If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.
                              I'm getting the same error when someone try to vote on a poll... directly from the main site, what is happening?

                              I have just upgrade to 3.7.0

                              Comment

                              Working...
                              X