Announcement

Collapse
No announcement yet.

email sending problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • email sending problems

    Hi all,

    Ive searched through the forums, and the user manual, trouble shooting etc for hours now, tried different fixes but cant seem to identify the problem I'm having so have reluctantly decided to post as I know how annoying repeat questions can be!

    I think a main problem I'm having is that Ive had my head in this for so long now that its all starting to look the same.... and things are starting to get fuzzy around the edges now... LOL!

    I don't really need help with how to fix the problem as such, just with identifying if the problem is on my end or my servers end.

    Since I first installed VB activation emails, and all other notification emails have not been working.

    They all get returned to me (through the Webmaster's Email ) with the following comment:

    From: Mail Delivery System [mailto:Mailer-Daemon@xxxxx.xxxxxxxx.com.au]
    Sent: Saturday, October 20, 2007 12:36 PM
    To: xxxxx@xxxxxxx.info
    Subject: Mail delivery failed: returning message to sender

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

    membersemailaddress@xxxxx.net.au
    Mail sent by user nobody being discarded due to sender restrictions in WHM->Tweak Settings
    When I do a diagnostic email test using an email address under a totally different domain the test comes back with no errors found, please check to see if you received the email.

    Then the test email will bounce and be sent back to me thru the webmasters email address with the above error email.

    BUT if I do the diagnostic email on a different email address, but same domain name (ie the same server) The diagnostic email says no errors found, and the email goes through to o the correct address perfectly - no bouncing back to the webmasters addy.

    SO. Is this a problem on my end with the settings in VB or with my host?

    Is this the problem?

    Email from my forums is blocked

    Error: unrouteable mail domain "****.com"
    This problem is caused by this option being checked in WebHost Manager for the server:

    Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)

    Unchecking this option should stop this problem. You will of course need to have root access to the server to do this. If you don't, then you'll need to ask your web host to do this for you.
    If so, is it something I can fix via the cpanel? or is it something I need to get my host to do on my account at their end?

  • #2
    This is a server issue, not a vB one:

    "Mail sent by user nobody being discarded due to sender restrictions in WHM->Tweak Settings "

    This needs to be fixed on the server level with WHM. It cannot be fixed in cPanel. You will need to contact your host about this.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thank you for your reply.

      Comment


      • #4
        ok, turns out I cant have that setting changed on my hosting account, so what do I do now to get around it???

        Comment


        • #5
          and if I 'Enable "-f" Parameter' to yes (safe mode is set to no)

          I still get the same error as above.

          Comment


          • #6
            Unfortunately this is still a server issue. You will need to contact your host about this.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              So theres no way that I can change vbullietn to send as admin@mydomain rather than nobody@xxxx ?

              Comment


              • #8
                No, it is the server that is doing that, not vB. Sorry I was unable to make that clear.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thanks Steve.

                  So I presume that using SMTP wont make any difference? Will it all still hit that same problem when going through the server?

                  Comment


                  • #10
                    That might work, depending on the SMTP server you use. At this point it's worth a shot.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Thanks again Steve. Ill give it a go.

                      Comment


                      • #12
                        It worked!

                        So for anyone with a similar problem. By using SMTP for email, I have been able to solve this problem.

                        Comment


                        • #13
                          Glad to hear it.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment

                          Working...
                          X