Announcement

Announcement Module
Collapse
No announcement yet.

simultaneous connections

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • simultaneous connections

    Hello,

    I'm receiving this msg from mysql...

    ---------------------------------------
    > Return-path: ;
    >
    > Received: from s7ronals by terry.hostingzoom.com with local (Exim 4.52)
    >
    > id 1GSI7T-0004XU-Lj
    >
    > for info@kazemalsaher.net; Tue, 26 Sep 2006 14:57:28 -0400
    >
    > To: info@kazemalsaher.net
    >
    > Subject: vBulletin Database Error!
    >
    > From: info@kazemalsaher.net
    >
    > Message-Id: ;
    >
    > Date: Tue, 26 Sep 2006 14:57:27 -0400
    >
    > Database error in vBulletin :
    >
    > mysql_connect() [;function.mysql-connect;]: User s7ronals_bb has already more
    than 'max_user_connections' active connections
    /home/s7ronals/public_html/vb/includes/class_core.php on line 279
    >
    > MySQL Error :
    >
    > Error Number :
    >
    > Date : Tuesday, September 26th 2006 @ 02:57:27 PM
    >
    > Script : http://www.kazemalsaher.net/vb/showthread.php?t=6015
    >
    > Referrer :
    >
    > IP Address : 86.108.14.253
    >
    > Username :
    >
    > Classname : vb_database
    ---------------------------------------



    I have called my Technical Support, and this is their msg
    ---------------------------------------
    As the error indicates:


    User s7ronals_bb has already more than 'max_user_connections' active connections
    /home/s7ronals/public_html/vb/includes/class_core.php on line 279




    This states that the mysql user s7ronals_bb has already set more than 24
    simultaneous connections to the database. Any furher connections will be blocked
    by the mysql server , please optimise your scripts to keep the connections
    under check.
    ---------------------------------------

    then.. I asked them
    ---------------------------------------
    > Hello,
    >
    > is it this option ??
    >
    > --------
    >
    > options['sessionlimit']" colSpan=2>Simultaneous Sessions Limit
    > options['sessionlimit']">Set this to the maximum number of simultaneous
    sessions that you want to be active at any one time. If this number is exceeded,
    new users are turned away until the server is less busy.
    >
    > Set this to 0 to disable this option.
    ---------------------------------------

    and they said..
    ---------------------------------------
    Nope. This is not the option.
    We run a customized daemon which checks the process execution time, process
    count aswell as CPU run time.

    I suggest hiring someone to optimize your scripts. Consider placing exit()'s at
    the end of every PHP script aswell as assuring that your script(s) are not using
    persistant mysql connections to avoid the max_user_processes.
    ---------------------------------------



    what can I do?

  • #2
    This is a server/host issue. The server has maxed out the number of MySQL connections your host allows you to have. You can try turning persistent connections off in your config.php:

    PHP Code:
            //      ****** MASTER DATABASE PERSISTENT CONNECTIONS ******
            //      This option allows you to turn persistent connections to MySQL on or off.
            //      The difference in performance is negligible for all but the largest boards.
            //      If you are unsure what this should be, leave it off. (0 = off; 1 = on)
    $config['MasterServer']['usepconnect'] = 0
    But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.

    Here is more info on this error:
    http://dev.mysql.com/doc/refman/4.1/...resources.html
    http://dev.mysql.com/doc/refman/5.0/...resources.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thank you sir,

      but I didn't find this

      PHP Code:
      // ****** MASTER DATABASE PERSISTENT CONNECTIONS ****** 
      in my config file

      Comment


      • #4
        Then you have modified your config.php file to remove it. This is a standard section. You need to add this back in.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          Then you have modified your config.php file to remove it. This is a standard section. You need to add this back in.
          can I add it anywhare in config file ?

          Comment


          • #6
            sorry, I find it..

            Its already switched ( off )

            Comment


            • #7
              Then you are at the mercy of your hosts. Your forums are simply too busy for the plan and server you are on.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              Working...
              X