Announcement

Collapse
No announcement yet.

Slow, high CPU usage after 3.5.2 upgrade

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slow, high CPU usage after 3.5.2 upgrade

    I upgraded to 3.5.2 from 3.5.1 yesterday, and ever since my forum has been very slow and my VPS CPU usage is way up. Before the upgrade I wouldn't see any spikes higher than 30-40% with a load average of under 1, now I'm seeing spikes up to 100% and the current load average is 3.04. And that's with only 3 users online.

    Any ideas what could be going on here?


  • #2
    I haven't heard of this issue coming from an upgrade to 3.5.2 from 3.51. Do you have any hacks or plugins installed?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      I haven't heard of this issue coming from an upgrade to 3.5.2 from 3.51. Do you have any hacks or plugins installed?
      Yes, quite a few:

      Archive Adsense 1.0
      Automatic Birthday Thread 1.0.1
      Automatic Welcome PM 1.0.4
      Commbull 3.5d
      Custom WOL Locations 1.0.2
      Digital Point Co-Op Ad Network 1.0
      e-steki Referrer Statistics 1.0
      Members who have visited the forum 4.11
      PhotoPlog 1.0.3
      phpAdsNew Integration 1.0.1
      Postbit Zodiac Sign 1.1
      Top 'X' Stats by InfiniteWebby 1.2.1
      uCash 1.1.1
      v3 Arcade 1.0.2
      vBE Evolution Style 1.1
      vBSEO :: Sitemap Generator 1.5
      vBShout 2.0 AJAX Shoutbox for vBulletin
      Welcome Headers

      However, I did not update/install/remove/change any of these immediately before or since I upgraded from 3.5.1 to 3.5.2.

      Comment


      • #4
        Try disabling your plugins just to see what happens to the server load.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by mikelbeck
          vBShout 2.0 AJAX Shoutbox for vBulletin
          That seems to be causing server load problems of late.

          Chris
          "Anyone who conducts an argument by appealing to Authority
          is not using his intelligence, he is just using his memory."
          ~~~
          Leonardo da Vinci

          Comment


          • #6
            To lessen the server load, try setting these options to 'No':

            Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Display Logged in Users?

            Admin CP -> vBulletin Options -> Forum Display Options (forumdisplay) -> Show Users Browsing Forums

            Admin CP -> vBulletin Options -> Thread Display Options -> Show Users Browsing Thread
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Ok, I'll give that a shot.

              CPU usage seems to be lower today, I made some changes to httpd.conf (found that a cPanel update had added a second include for mod_security rules) and it seems to be slightly better. It's still higher than it used to be, but at least now it's at a reasonable level.

              I tried turning off vbShout but it didn't make much of a difference.

              Comment


              • #8
                Originally posted by Steve Machol
                To lessen the server load, try setting these options to 'No':

                Admin CP -> vBulletin Options -> Forum Display Options (forumdisplay) -> Show Users Browsing Forums

                Admin CP -> vBulletin Options -> Thread Display Options -> Show Users Browsing Thread
                By turning these two options on and off, I was able to make the CPU usage rise and fall. I've left them off for the time being and my CPU average is low.

                Thanks for the help.

                Comment


                • #9
                  exactly same thing happened to me after the upgrade.. in fact i am now in the middle of moving to a new very expensive dedicated server because i assumed the upgrade wouldnt be at fault.. my traffic is actually lower now since the upgrade 3 days ago.. but after the upgrade the server kept crashing like mad.

                  Comment


                  • #10
                    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Display Logged in Users?


                    i dont see above settings why? And please look here whatis wrong ?http://www.gsmciler.com/phpinfo.php
                    Last edited by ombossman; Wed 28th Dec '05, 9:29am.

                    Comment


                    • #11
                      Admin CP -> vBulletin Options -> Forum Home Page Options -> Display Logged in Users?
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Originally posted by Steve Machol
                        Admin CP -> vBulletin Options -> Forum Home Page Options -> Display Logged in Users?

                        ok tnx for reply my post but my problem contunuie for example enable plugin hook sistem forum very slow but disable plugin hook sistem my forum faster how to solve big problem i want use plugin sistem

                        Comment

                        Working...
                        X