Announcement

Collapse
No announcement yet.

mysql error: Duplicate entry ... for key 1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • mysql error: Duplicate entry ... for key 1

    Oh no... I tried to convert my forums to InnoDB, it went wrong so I switched it back.. now I get this error when I post a reply/new thread:

    Have I really broken it or do I have any hope?

    Database error in vBulletin 3.0.5:

    Invalid SQL:
    INSERT INTO post
    (threadid, parentid, title, username, userid, dateline, pagetext, allowsmilie,
    showsignature, ipaddress, iconid, visible, attach)
    VALUES
    (1733735, 0, 'Test',
    'Ian Cunningham', 1, 1117874948,
    'Test', 1, 1,
    'xxx.xx.xxx.xxx', 0, 1, 0)

    mysql error: Duplicate entry '5151714' for key 1

    mysql error number: 1062
    How can I get the keys to go back to normal?
    Last edited by Ian Cunningham; Sat 4th Jun '05, 1:10am.
    Laptop Forums

  • #2
    Strange. For some reason this query is not entering anything into the postid field. Nor is there any indiication that it is inserting '5151714' anywhere at all.

    The first thing I recommend is that you reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks Steve, I converted a backup to the normal DB format and then repaired it using keycache. Took a while, but now works.

      Very strange! Taught me a lesson though - MySQL servers are not toys!
      Laptop Forums

      Comment


      • #4
        I am having the same error OUT OF THE blue, but on a system that has been up for over a year, and no changes in 2 weeks at all. All of a sudden it's doing the same thing.

        Can you help, Steve, or anyone else. I posted here:
        http://www.vbulletin.com/forum/showthread.php?t=155953

        Comment


        • #5
          Iam using Jfusion to connect with Joomla and i got this error when I reedit my site to make a user a Superadmin

          Comment

          Working...
          X