Announcement

Collapse
No announcement yet.

Install/Linux/Apache ... install.php

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install/Linux/Apache ... install.php

    Hi, (my first post here)

    I am trying to install vbulletin on a Linux/RH6.1 server, running Apache webserver. In the installation guide it is said that you should run the script install.php
    I have the following

    [url]http://webserver/forums/admin/install.php[/url]

    where webserver is the name of ..... yeah your right, my "webserver". I can see the install.php script, but when I try to execute it looks for files under /php3/php/forums ...?? It looks to me as a setting in my Apache webserver, but I have put in the line

    AddType application/x-httpd-php3 .php

    in my httpd.conf file in Apache configuration.

    Question: Am I supposed to run the install script install.php from the browser or from the Unix command line ???or can I do both ..??

    Please help

  • #2
    Needs to be run from the browser.

    Comment


    • #3
      Apache settings ..

      Hi,

      Thanks for your reply Greg ..
      When I try to execute the installscript from the browser it looks for /php3/php/ ..... ???
      Can anyone help me out here ...
      I have the [url]http://webserver/forums/admin/install.php[/url]
      but apprently I am put into /php3/ ... when I try to extecute.

      Thanks in advance

      Comment


      • #4
        I could be wrong, but you may need to change a configuration in your server conf files to point to the proper directory that PHP is installed.

        It looks like it wants to look in /php3/php but since you are probably installed elsewhere, you might have to create a redirect to if install.php is looking for php3/ it is redirected to the proper directory.

        uh... i think
        Brian Shea (G+)
        FallenBrothers.com and SevenSages.com

        Comment


        • #5
          Can`t execute script install.php !!!!!

          Hi again,

          It is getting on my nerves now ...... so please help.

          When I try to execute the install script, ie.

          [url]http://webserver/forums/admin/install.php[/url]

          I just get the text of the script in my browser.
          That means my browser/webserver dosn`t convert the
          <?p into something which is known to it ???

          I am useing Apache as a CGI.

          I have put this into the httpd.conf file

          ScriptAlias /php3/ "usr/local/bin"
          AddType application/x-httpd-php3.php3
          Action application/x-httpd-php3 "/php3/php"

          so why wouldn`t it execute the god damned script ... ??? and
          only shows it up in my face as a text file in my browser ??

          Thanks in advance

          Comment


          • #6
            Don't know if this would cause this problem, but this line is wrong:
            [b]ScriptAlias /php3/ "usr/local/bin"[/b]

            Should be:
            [b]ScriptAlias /php3/ "[i]/[/i]usr/local/bin"[/b]

            Comment


            • #7
              NO

              No I am afraid not ...

              It was only a spelling error from my side ... sorry ...

              But in my frustration and anger I sometime write very fast ...

              But thanks anyway

              Comment


              • #8
                It would seem that PHP is not set up correctly (some what stating the obvious :) ).

                Have a look at the phptest.php file included in the archive of vBulletin. Upload that to the server, and if it does not tell you that PHP is installed correctly, then that is your problem. You should contact your sysadmin of host to get them to do it.

                FYI, I run PHP as a CGI under [b]Win 32[/b]. These are the lines that I have in my Apache httpd.conf:

                [code]
                ScriptAlias /php3/ "f:/progra~1/apache~1/php/"

                AddType application/x-httpd-php3 .php

                Action application/x-httpd-php3 "/php3/php.exe"
                [/code]

                You will probably want to change the path after ScriptAlias to refer to where you have got PHP installed.

                You may want to try renaming the phptest.php file to phptest.php3 and see if it works then.


                John
                John Percival

                Artificial intelligence usually beats real stupidity ;)

                Comment


                • #9
                  install.php

                  Hi,
                  Thanks for help.
                  First I my say that I am using Linux RH6.1
                  My php3-3.0.16 is installed in the directory
                  /root/php-3.0.16/..

                  After I had compiled php I copied the php file
                  /root/php-3.0.16/php to /usr/local/bin, where scripts normal
                  executes from. So should the "ScriptAlias" point to /usr/local/bin ??? and should "Action Application" be
                  /root/php-3.0.16/php ???? or just "/php3/php" ??

                  Comment


                  • #10
                    STILL A PROBLEM

                    My problem is still there in case anybody looked at this.

                    I think my problem is that my webserver dos`nt recongnize the .php extension. Where do you set that mime-type in the Apache webserver ??? Nothing seems to work ...

                    Is it easier to delete my apache webserver and install a new one were php included as a module ???

                    I am running php as CGI and that extension is in the webserver, but how to put in .php .

                    [Edited by netsoum on 05-31-2000 at 01:40 PM]

                    Comment


                    • #11
                      Take a look at this post and see if this helps...

                      [url]http://vbulletin.com/forum/showthread.php?threadid=660[/url]
                      RobRJ
                      www.jazweb.net - a growing concern

                      see my vBulletin @ www.wnsp.com/soundoff

                      Comment


                      • #12
                        It works noW !!

                        Hi again,

                        Just to say thanks for all your help and support.
                        I didn`t get it to work the way I tried in the first place.
                        Instead I compiled my Apache webserver with/as a php module,
                        and that worked first time.
                        There is a good description, which I used, on [url]http://www.php.net[/url]

                        Comment

                        Working...
                        X