Announcement

Collapse
No announcement yet.

vBulletin 3.7.2 PL2 and 3.6.10 PL4 Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin 3.7.2 PL2 and 3.6.10 PL4 Released

    vBulletin 3.7.2 PL2 / vBulletin 3.6.10 PL4

    An XSS flaw related to JavaScript escaping has been identified. This could allow an attacker to carry out an action as a user or obtain access to a user's account. To resolve this issue, it is necessary to release patch level versions of vBulletin 3.7.2 and 3.6.10.

    This flaw was discovered by Federico Muttis.

    The upgrade process is the same as previous patch level releases - simply download the patch from the Members Area, extract the files and upload to your webserver, overwriting the existing files. There is no upgrade script required.

    As with all security-based releases, we recommend that all customers upgrade as soon as possible in order to prevent any potential damage resulting from the flaw being exploited.


    vBulletin 3.7.3 and 3.6.11 to be Released Next Week

    In line with our new scheduled maintenance release policy, a new release for 3.6 and 3.7 will be made on Tuesday, August 26th.

    These releases will contain bug fixes, but will also address a situation related to users that use their username as their password. In 3.6.11 and 3.7.3, this will be completely disallowed. Users affected by this will be forced to change their password on their first login. Additionally, a tool will be provided to email affected users with a new password. Please be aware of these potential compatibility changes when upgrading.

    This release will be mentioned in the security bulletin sent out to customers today, but we will not send a further notification next week when 3.7.3 and 3.6.11 are released. Watch your Admin CP News, or the latest version check in the Admin CP to see when the new version is available. Alternatively, keep an eye on this forum for the 3.7.3 and 3.6.11 announcements.


    Upgrading from 3.7.2, 3.6.10 or their patch level versions

    If you are already running 3.7.2, 3.6.10 or their patch level versions, the process you will be required to follow to make your board immune to the XSS problem is very simple.

    There is no need to run an upgrade script if you are already running 3.7.2, 3.6.10 or their patch level versions.

    Visit the Patches section of the vBulletin Members' Area and download either the patch for 3.7.2, or the patch for 3.6.10, according to the version you are currently running, then extract the files from the archive you downloaded, then upload the files to your board via FTP etc., overwriting the existing files. This will update your version to the PL1 or PL3 release respectively.

    The 3.7.2 PL2 patch file includes the PL1 fix.
    The 3.6.10 PL4 patch file also includes the PL1, PL2, and PL3 fixes.


    Upgrading from Versions Earlier than 3.7.2 or 3.6.10

    If you are not already running 3.7.2 or 3.6.10, you should download the most latest version from the Members' Area and perform an upgrade as normal.

    Full instructions for upgrading vBulletin are available here.


    Download vBulletin 3.7.2 PL2 or 3.6.10 PL4

    As usual, both versions released today are available for all customers with valid, active licenses to download from the vBulletin Members' Area.

    vBulletin Members Area
Working...
X