Announcement

Announcement Module
Collapse
No announcement yet.

Thread disappeared without a trace

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Thread disappeared without a trace

    I am trying to get to the bottom of what happened to a thread on my website. I run a somewhat larger board with about 3000 post a day. At the time I had a little over 200 users online. About 50 were viewing a certain thread when it vanished. I checked the moderator logs and nothing. I am the only one with access to the server and I didnt do it. What could cause this and what should I look for. Vbulletin 4.1.11 on a dedicated quadcore xenon with 2gb of RAM. I had around 700 on one thread earlier this year so I know the server should be able to handle it. There were a lot of gifs being posted.

  • #2
    Do you see the thread in your database?


    Vote to have Javascript refactored in vB5

    Comment


    • #3
      No when I logged into myphpadmin it was missing.

      Comment


      • #4
        Bump

        Comment


        • #5
          Then it's completely gone I'm afraid. The only reason a new thread will disappear is if:

          - someone with access has deleted it
          - the database has rolled back to just before it was created


          Vote to have Javascript refactored in vB5

          Comment


          • #6
            Originally posted by Trevor Hannant View Post
            Then it's completely gone I'm afraid. The only reason a new thread will disappear is if:

            - someone with access has deleted it
            - the database has rolled back to just before it was created
            So there is no way a thread could crash and disappear?

            Comment


            • #7
              Is there any forum you created not visible on forum page that is not in use.

              Comment


              • #8
                I'm having this issue with a thread. I moved the thread a few days ago with an expiring redirect, and the thread was there for at least some time after I moved it, because I personally saw several later posts in that thread. The last activity in my log is me moving the thread, but now the thread is nowhere to be found. Mod log:





                Now if I click on that thread, I get "no thread specified."

                I am the only one who has access to the ACP and the only one who has access to the servers (other than the usual people at the host, etc.), and the thread was a couple of days old, so I don't think that it's possible to be some sort of reversion issue.


                ETA: no add-ons, modifications, upgrades, etc. have occurred since well before this thread was started. I have not actually logged into the server for at least a couple of weeks.

                Comment


                • #9
                  This has just happened to me again. The thread immediately before it and immediately after it (in sequence) are un-touched, but the thread I was replying to literally disappeared while I was replying to it. The thread is more than one day old, so this cannot be a database reversion, as my database is backed up each night at 3:00 AM.

                  What on earth is going on here?

                  Comment


                  • #10
                    Threads don't simply disappear without trace, they're either deleted via the site or from the database or they're merged into other threads without a redirect. There's no script in the default vBulletin to prune threads or delete threads automatically.


                    Vote to have Javascript refactored in vB5

                    Comment


                    • #11
                      Originally posted by Trevor Hannant View Post
                      Threads don't simply disappear without trace, they're either deleted via the site or from the database or they're merged into other threads without a redirect. There's no script in the default vBulletin to prune threads or delete threads automatically.
                      My log shows no activity since November 5, so it's not possible for this to be a moderator or admin action.

                      Any other suggestions?

                      Comment


                      • #12
                        Do the posts still exist in the database or was the whole thing erased from both the thread table and the post table?

                        Which log are you looking at? Have you looked at the Moderator Log and the Control Panel Log?

                        Please don't PM or VM me for support - I only help out in the threads.
                        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                        Want help modifying your vbulletin forum? Head on over to vbulletin.org
                        If I post CSS and you don't know where it goes, throw it into the additional.css template.

                        W3Schools <- awesome site for html/css help

                        Comment


                        • #13
                          Originally posted by Lynne View Post
                          Do the posts still exist in the database or was the whole thing erased from both the thread table and the post table?

                          Which log are you looking at? Have you looked at the Moderator Log and the Control Panel Log?
                          I have not yet looked at the database itself. When I put in the sequence number of the thread, it just says invalid thread specified. In this case, it's thread #8110. Thread 8109 and thread 8111 are just as right as rain, but it's like 8110 never existed.

                          I was speaking of the mod and admin CP logs. Last moderation action taken was to edit a thread title (different thread) on Nov. 5, done from my admin account. Last ACP action was moderating a user on Nov. 5.

                          I have one admin account which I use solely for admin actions. When I post, I use a "civilian" account. I actually didn't even have my admin account logged in at the time. We're a small board, only about 50 active members, so I have just three moderators, and none of the three of them was logged in anywhere near the time that the thread disappeared.

                          So, in short, I don't see any way that this could have been some sort of mod or admin error, not only because the opportunity doesn't appear to have been there, but also because there's no log of anyone doing anything to that thread.

                          - - - Updated - - -

                          Here's the database:



                          Thread 8310 just isn't there.

                          Comment


                          • #14
                            That is the thread table. Check the post table and see if any posts belonging to threadid 8310 are there.

                            What modifications do you have installed?

                            Please don't PM or VM me for support - I only help out in the threads.
                            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                            Want help modifying your vbulletin forum? Head on over to vbulletin.org
                            If I post CSS and you don't know where it goes, throw it into the additional.css template.

                            W3Schools <- awesome site for html/css help

                            Comment


                            • #15
                              Originally posted by Lynne View Post
                              That is the thread table. Check the post table and see if any posts belonging to threadid 8310 are there.
                              None. It's like it never existed.




                              Originally posted by Lynne View Post
                              What modifications do you have installed?
                              Not a whole lot:

                              Country Flag In Who's Onlne 1.0.0
                              Forum Runner 4.2.0 *disabled*
                              ibProArcade for vBulletin 2.7.2
                              PostRelease 4.2.0 *disabled*
                              Quote Notification 1.1.0
                              Skimlinks Plugin 4.2.0
                              TH User Awaiting Moderation Email 1.1
                              uCash 4.0.1
                              Use Original Thread for Comments 4.0-0.1 a2
                              vBH - Add new tabs 1.2 1.2
                              vbStopForumSpam 0.61
                              vBulletin Blog 4.2.0
                              vBulletin CMS 4.2.0
                              Who Has Read a Thread 4.1.1 "* Disabled by vBulletin 4.2 * Display members who have read a thread."

                              Comment

                              Working...
                              X