Announcement

Announcement Module
Collapse
No announcement yet.

Warning: Declaration of vBForum_Item_SocialGroupMessage

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Warning: Declaration of vBForum_Item_SocialGroupMessage

    Hello after upgrading so many problem display...that i solved now last error is display that is under way
    Code:
    Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupmessage.php on line 261
    
    Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupdiscussion.php on line 337
    So please tell me how can i do that i disalbed all plugin but nothing happen...........reply me soon.

  • #2
    same... me to .

    Comment


    • #3
      You can turn off the display of warnings using this line of code at the top of your config.php under <?:

      error_reporting(E_ALL ^ (E_NOTICE | E_WARNING | E_DEPRECATED));

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to vbulletin.org
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools &lt;- awesome site for html/css help

      Comment


      • #4
        Originally posted by Lynne View Post
        You can turn off the display of warnings using this line of code at the top of your config.php under <?:

        error_reporting(E_ALL ^ (E_NOTICE | E_WARNING | E_DEPRECATED));
        Unfortunately that didn't work for me ....
        <?php
        error_reporting(E_ALL ^ (E_NOTICE | E_WARNING | E_DEPRECATED));
        ...
        ...

        Comment


        • Senfgurke
          Senfgurke commented
          Editing a comment
          me too :-(

        • Muhammad Rahman
          Muhammad Rahman commented
          Editing a comment
          me to .. wait for update core

      • #5
        This is not just warning you could simply ignore. The page is totally not usable. The search.php page to be exact.

        Comment


        • #6
          The "fix" also doesn't work for me.

          Has vBulletin 4.2.2 not been tested before the release?

          Comment


          • #7
            Overwriting the 2 files with v4.2.1 doesn't work either.

            Comment


            • #8
              This is Warning i have too and

              Warning: Only variables should be passed by reference in ..../newreply.php on line 389

              Comment


              • #9
                Originally posted by Senfgurke View Post
                This is Warning i have too and

                Warning: Only variables should be passed by reference in ..../newreply.php on line 389
                Please disable all plugins on your board and tell us if the problem persists.

                To do this, edit your vBulletin config.php file currently on the server by adding the following line after the <?php line:
                PHP Code:
                define('DISABLE_HOOKS'true); 
                Then reupload the config.php file into your forum's includes folder.
                MARK.B | vBULLETIN SUPPORT
                NEW Try the next version of vBulletin on my unofficial 5.1.2 Demo

                Comment


                • #10
                  Originally posted by Mark.B View Post

                  Please disable all plugins on your board and tell us if the problem persists.

                  To do this, edit your vBulletin config.php file currently on the server by adding the following line after the <?php line:
                  PHP Code:
                  define('DISABLE_HOOKS'true); 
                  Then reupload the config.php file into your forum's includes folder.
                  Hello Mark
                  sorry Iam a rookie but i havent Plugins intalled
                  iam using PHP 5.4

                  Comment


                  • #11
                    Originally posted by woodmj View Post

                    Unfortunately that didn't work for me ....
                    <?php
                    error_reporting(E_ALL ^ (E_NOTICE | E_WARNING | E_DEPRECATED));
                    ...
                    ...
                    You can try turning display errors off completely.

                    ini_set('display_errors',0);


                    While the software was tested, different server configurations can pick up different issues. We try to be thorough but can't catch everything. This warning does not occur on my test installation using PHP 5.5.2.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud site.
                    Please do not PM me for support unless I specifically ask for information to be delivered that way.

                    Comment


                    • #12
                      I have the same errors. My host will only take me up to PHP Version 5.3.27. For grins I looked at my test server and saw the same errors and it is on PHP Version 5.4.19 and has the same issue. My host said they have no idea when we will see 5.5.2 or above.

                      This is not the only error I have seen, I have seen almost all of the same errors as the others in other threads.

                      I have to say that, up to this upgrade, they have all been smooth as silk...this one has been a disaster and now my hands are tied as I run all the restores on my forums.

                      And not to be a smart ass, but didn't php 5.5 just release like a few months back? If my memory is right, then why in the world would you not consider testing back to 5.3 and 5.4?
                      Last edited by weave; Wed 9th Oct '13, 9:27pm.

                      Comment


                      • #13
                        Originally posted by Wayne Luke View Post

                        You can try turning display errors off completely.

                        ini_set('display_errors',0);


                        While the software was tested, different server configurations can pick up different issues. We try to be thorough but can't catch everything. This warning does not occur on my test installation using PHP 5.5.2.
                        How about in lower versions of PHP? Most of the issues in 4.2.2 occur in PHP 5.3. vBulletin documentation requires PHP 5.2.0 and greater. So you should have tested 4.2.2 to PHP 5.3 and 5.2 thoroughly as well.

                        Comment


                        • #14
                          The same to me, fresh install 4.2.1 then upgrade to 4.2.2 version. (Appears in some parts in admincp and in search function)
                          Code:
                          <b>Warning</b>: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in <b>..../packages/vbforum/item/socialgroupmessage.php</b> on line <b>261</b><br /><br /><b>Warning</b>: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in <b>..../packages/vbforum/item/socialgroupdiscussion.php</b> on line <b>337</b>

                          Comment


                          • #15
                            I think I am getting these too, and others:

                            When I go to CMS, I get:

                            Warning: Declaration of vBCms_Item_Content::setItemId() should be compatible with that of vB_Model::setItemId() in ..../packages/vbcms/item/content.php on line 26

                            When I install addons (modifications), I get:

                            Warning: Declaration of vB_Database_Alter_MySQL::add_index() should be compatible with that of vB_Database_Alter::add_index() in ..../includes/class_dbalter.php on line 882

                            Warning: Declaration of vB_Database_Alter_MySQL::add_field() should be compatible with that of vB_Database_Alter::add_field() in ..../includes/functions_log_error.php on line 882

                            Warning: Declaration of vB_Database_Alter_MySQL::drop_field() should be compatible with that of vB_Database_Alter::drop_field() in ..../includes/functions_log_error.php on line 882

                            Warning: Declaration of vB_Database_Alter_MySQL::query() should be compatible with that of vB_Database_Alter::query() in ..../includes/functions_log_error.php on line 882

                            In Admincp:

                            Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupmessage.php on line 261

                            Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupdiscussion.php on line 337

                            Nelson
                            www.Hobby-Machinist.com

                            Comment


                            • mr3oobqatar
                              mr3oobqatar commented
                              Editing a comment
                              I have the same problem that
                          Working...
                          X