Announcement

Announcement Module
Collapse
No announcement yet.

Deprecated

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Deprecated

    I suddenly have this problem

    Deprecated: Assigning the return value of new by reference is deprecated in.................... /home/public_html/forum/includes/init.php on line 55

    and a few others

    im on 3.84 any ideas
    www.tabletennistalk.co.uk

  • #2
    Try disabling your modifications/plugins and see if you still have this problem.
    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    PHP Code:
    define('DISABLE_HOOKS'true); 

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools &lt;- awesome site for html/css help

    Comment


    • #3
      is this not a php upgrade problem?

      or do we not know on here?
      www.tabletennistalk.co.uk

      Comment


      • #4
        ********* thump*********
        www.tabletennistalk.co.uk

        Comment


        • #5
          Originally posted by basilrath View Post
          is this not a php upgrade problem?

          or do we not know on here?
          What version of php are you using? You said nothing about an upgrade of php in your first post.

          Also, please read the forum rules regarding bumping. You should not bump your threads within 24 hours.

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools &lt;- awesome site for html/css help

          Comment


          • #6
            Originally posted by basilrath View Post
            ********* thump*********
            you bumped this after 13 mins

            not cool..
            http://brandonsheley.org/services - Webmaster Services

            Comment


            • #7
              Sorry about that. Our host has up-graded php to 5.3 and this has suddenly occured and they say it is a fault in the vb script.
              www.tabletennistalk.co.uk

              Comment


              • #8
                It's in the bug tracker with the fix. http://www.vbulletin.com/forum/proje...?issueid=28380

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools &lt;- awesome site for html/css help

                Comment


                • #9
                  Are we seriously saying that VBulletin 3.8.4 wont run with php 5.3?

                  The story so far ...........

                  my host upgrades to php 5.3
                  one of my sites is then down ....... simple

                  the solution im told is the "poor mans" fix in the bug tracker link !

                  Surely we have a real fix available so the site can run on 5.3

                  i have tried the
                  define('DISABLE_HOOKS', true);


                  still no joy


                  Last edited by basilrath; Mon 4th Jan '10, 2:39pm.
                  www.tabletennistalk.co.uk

                  Comment


                  • #10
                    Did you read the bug report at all? The fix is posted right in there.

                    Please don't PM or VM me for support - I only help out in the threads.
                    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                    Want help modifying your vbulletin forum? Head on over to vbulletin.org
                    If I post CSS and you don't know where it goes, throw it into the additional.css template.

                    W3Schools &lt;- awesome site for html/css help

                    Comment


                    • #11
                      yes read the bug report (as you would given the fact you did say "read the bug report")

                      ok in simple terms i dont understand the fix - so how do we stand now .............. host say its the script -

                      im taking it the fix is "Turn of show_errors errors in php.ini."


                      www.tabletennistalk.co.uk

                      Comment


                      • #12
                        If you are already running 3.8.4, then you need to modify your php.ini file to not show errors. I believe the setting is called display_errors, however you should ask for clarification in the bug report or put in a support ticket if need be.

                        Please don't PM or VM me for support - I only help out in the threads.
                        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                        Want help modifying your vbulletin forum? Head on over to vbulletin.org
                        If I post CSS and you don't know where it goes, throw it into the additional.css template.

                        W3Schools &lt;- awesome site for html/css help

                        Comment

                        Working...
                        X